summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-01 00:07:27 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-01 15:29:12 +0200
commitc0ef8ae22da4bb006abbb8a5b6cf99ec3e2ae335 (patch)
tree932cef1ae0f07c406cbcfc6f21df59b08d1367f9 /gnu/packages
parent2e402618f653f0801358cad74e3030972c975387 (diff)
downloadpatches-c0ef8ae22da4bb006abbb8a5b6cf99ec3e2ae335.tar
patches-c0ef8ae22da4bb006abbb8a5b6cf99ec3e2ae335.tar.gz
gnu: json-c: Update to 0.13.1.
* gnu/packages/web.scm (json-c): Update to 0.13.1. [source](snippet): Remove obsolete substitution. [arguments]: Remove.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2b88e6920d..f0fce05c9e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -524,7 +524,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.13")
+ (version "0.13.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -532,7 +532,7 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0kf2594kxcfga6x0mvwzj2qg8pgxhjkibc16ghnw85mdx45ph5h3"))
+ "0ws8dz9nk8q2c0gbf66kg2r6mrkl7kamd3gpdv9zsyrz9n6n0zmq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -541,13 +541,8 @@ data.")
;; run 'autoheader'.
(set-file-time "config.h.in"
(stat "aclocal.m4"))
-
- ;; Don't try to build with -Werror.
- (substitute* (find-files "." "Makefile\\.in")
- (("-Werror") ""))))))
+ #t))))
(build-system gnu-build-system)
- (arguments '(#:parallel-build? #f
- #:parallel-tests? #f))
(home-page "https://github.com/json-c/json-c/wiki")
(synopsis "JSON implementation in C")
(description