summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-09-06 01:10:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-09-26 23:17:54 +0200
commitd31a532417a3e92e6d1acde238ff8859c1f970b5 (patch)
treed21eebf760607830956023423d2ad593211b6f94 /gnu/packages
parent99fcefb94c19c25dfa77f28fc8569da6d3aca64f (diff)
downloadpatches-d31a532417a3e92e6d1acde238ff8859c1f970b5.tar
patches-d31a532417a3e92e6d1acde238ff8859c1f970b5.tar.gz
gnu: Add emacs-flycheck-grammalecte.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bea8463cd2..7e1e9bfefc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -89,6 +89,7 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages code)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages dictionaries)
#:use-module (gnu packages emacs)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
@@ -3092,6 +3093,60 @@ boundaries defined by syntax highlighting.")
for Flow files.")
(license license:gpl3+))))
+(define-public emacs-flycheck-grammalecte
+ (package
+ (name "emacs-flycheck-grammalecte")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://git.deparis.io/"
+ "flycheck-grammalecte/snapshot/"
+ "flycheck-grammalecte-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wjm9xyra870pci4bcrbnc9x66x18mi7iz08rkxa4clxv28xzryb"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include '("\\.(el|py)$")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-python
+ ;; Hardcode python3 executable in the Emacs library.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python3 (string-append (assoc-ref inputs "python")
+ "/bin/python3")))
+ (substitute* "flycheck-grammalecte.el"
+ (("python3") python3))
+ #t)))
+ (add-after 'install 'link-to-grammalecte
+ ;; The package expects grammalecte to be in a sub-directory.
+ ;; Symlink it there from the store.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((grammalecte (assoc-ref inputs "grammalecte"))
+ (out (assoc-ref outputs "out"))
+ (version ,(version-major+minor (package-version python))))
+ (with-directory-excursion
+ (string-append out
+ "/share/emacs/site-lisp/guix.d/"
+ "flycheck-grammalecte-" ,version)
+ (symlink (string-append grammalecte "/lib/"
+ "python" version "/site-packages/"
+ "grammalecte")
+ "grammalecte"))
+ #t))))))
+ (inputs
+ `(("grammalecte" ,grammalecte)
+ ("python" ,python)))
+ (propagated-inputs
+ `(("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://git.deparis.io/flycheck-grammalecte/")
+ (synopsis "Integrate Grammalecte with Flycheck")
+ (description "Integrate the French grammar and typography checker
+Grammalecte with Flycheck to automatically look for mistakes in your writings.
+It also provides an easy way to find synonyms and antonyms for a given
+word (to avoid repetitions for example).")
+ (license license:gpl3+)))
+
(define-public emacs-elisp-demos
(package
(name "emacs-elisp-demos")