summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-05-08 23:00:12 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-08 23:00:12 +0800
commitf09520db01822f338e1e7391d257a15165fb37a3 (patch)
tree9e9cc5982beb42027f8395ee5d2efead9270b1a5 /gnu/packages
parent041d0ff8806ccf0690e55a1daab2f378cc57fc75 (diff)
downloadpatches-f09520db01822f338e1e7391d257a15165fb37a3.tar
patches-f09520db01822f338e1e7391d257a15165fb37a3.tar.gz
gnu: Add libgames-support.
* gnu/packages/gnome.scm (libgames-support): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 132fcc3b13..65ff4518d5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2911,6 +2911,42 @@ write applications that need to store structured data as well as make complex
queries upon that data.")
(license license:lgpl2.1+)))
+(define-public libgames-support
+ (package
+ (name "libgames-support")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0rms2ksiv7j9944km7r87q22nh05si1fisn5xm3z4zy5vpcfi5mh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; tests require a writable HOME.
+ (setenv "HOME" (getcwd))
+ #t)))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (propagated-inputs
+ ;; Required by libgames-support-1.0.pc
+ `(("gtk+" ,gtk+)
+ ("libgee" ,libgee)))
+ (home-page "https://www.gnome.org/")
+ (synopsis "Useful functionality shared among GNOME games")
+ (description
+ "libgames-support is a small library intended for internal use by
+GNOME Games, but it may be used by others.")
+ (license license:lgpl3+)))
+
(define-public gnome-klotski
(package
(name "gnome-klotski")