summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-24 20:40:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-24 21:18:11 +0100
commit50233d95707389eb526587c04f58b4281ebcaa6c (patch)
tree2e89e541b4157d305adfe328da51fd8c90addef2 /gnu/packages
parentbbb2bd50dcb160d8e60fc657b96f1b6739cd8d89 (diff)
downloadpatches-50233d95707389eb526587c04f58b4281ebcaa6c.tar
patches-50233d95707389eb526587c04f58b4281ebcaa6c.tar.gz
gnu: flint: Unconditionally return #T from build phases.
* gnu/packages/algebra.scm (flint)[arguments]: Use INVOKE in "configure" phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/algebra.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index b19b7e692f..757b1111d6 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -357,11 +357,11 @@ or text interfaces) or as a C++ library.")
(mpfr (assoc-ref inputs "mpfr")))
;; do not pass "--enable-fast-install", which makes the
;; homebrew configure process fail
- (zero? (system*
- "./configure"
+ (invoke "./configure"
(string-append "--prefix=" out)
(string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr)))))))))
+ (string-append "--with-mpfr=" mpfr))
+ #t))))))
(synopsis "Fast library for number theory")
(description
"FLINT is a C library for number theory. It supports arithmetic