summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2019-10-25 12:24:03 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-25 13:32:56 +0200
commit7eea1de74e0582b9a074db2b1b43bbc42808621c (patch)
tree884a669e6eefbf45d25fac91cb8778c9c2d0f8bf /gnu/packages
parent0c558aa985161b74b80319dbefccf9eab537ef4e (diff)
downloadpatches-7eea1de74e0582b9a074db2b1b43bbc42808621c.tar
patches-7eea1de74e0582b9a074db2b1b43bbc42808621c.tar.gz
gnu: Add ddcci-driver-linux.
* gnu/packages/linux.scm (ddcci-driver-linux): Add variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1249cc5820..32eaef244e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -938,6 +938,52 @@ and should be used with caution, especially on untested models.")
between the CDemu userspace daemon and linux kernel.")
(license license:gpl2+)))
+(define-public ddcci-driver-linux
+ (package
+ (name "ddcci-driver-linux")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vkkja3ykjil783zjpwp0vz7jy2fp9ccazzi3afd4fjk8gldin7f"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda args
+ (for-each
+ (lambda (module)
+ (with-directory-excursion module
+ (apply (assoc-ref %standard-phases 'build) args)))
+ '("ddcci" "ddcci-backlight"))
+ #t))
+ (replace 'install
+ (lambda args
+ (for-each
+ (lambda (module)
+ (with-directory-excursion module
+ (apply (assoc-ref %standard-phases 'install) args)))
+ '("ddcci" "ddcci-backlight"))
+ #t)))))
+ (home-page "https://gitlab.com/ddcci-driver-linux/ddcci-driver-linux")
+ (synopsis "Pair of Linux kernel drivers for DDC/CI monitors")
+ (description "This package provides two Linux kernel drivers, ddcci and
+ddcci-backlight, that allows the control of DDC/CI monitors through the sysfs
+interface. The ddcci module creates a character device for each DDC/CI
+monitors in @file{/dev/bus/ddcci/[I²C busnumber]}. While the ddcci-backlight
+module allows the control of the backlight level or luminance property when
+supported under @file{/sys/class/backlight/}.")
+ (license license:gpl2+)))
+
;;;
;;; Pluggable authentication modules (PAM).