summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-10-27 07:59:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-10-27 07:59:35 +0100
commit6f921bfdaa91fee55bd65d38d6c6b975e8261f80 (patch)
tree899310f00eaf4d5168245dcfd430eb8797222314 /gnu/packages
parent534716362773b9e2f3b9174ab418f07e2ef13e3f (diff)
downloadpatches-6f921bfdaa91fee55bd65d38d6c6b975e8261f80.tar
patches-6f921bfdaa91fee55bd65d38d6c6b975e8261f80.tar.gz
gnu: Add r-deriv.
* gnu/packages/cran.scm (r-deriv): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70b468dc84..8f00e8dfb8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6526,6 +6526,28 @@ comparisons to Cohen's d are offered based on Huberty & Lowman's Percentage of
Group (Non-)Overlap considerations.")
(license license:gpl2)))
+(define-public r-deriv
+ (package
+ (name "r-deriv")
+ (version "3.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Deriv" version))
+ (sha256
+ (base32
+ "0hlqm216bg3l79gq6m0am0xz6vd3l2hgjnjm6lym3mkmgkka4kxw"))))
+ (properties `((upstream-name . "Deriv")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/Deriv")
+ (synopsis "Symbolic differentiation")
+ (description
+ "This package provides an R-based solution for symbolic differentiation.
+It admits user-defined functions as well as function substitution in arguments
+of functions to be differentiated. Some symbolic simplification is part of
+the work.")
+ (license license:gpl3+)))
+
(define-public r-doby
(package
(name "r-doby")