summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:28:57 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:28:57 +0100
commit4631e6c9cd83c07197175ac3483c49ee757e5916 (patch)
tree5f759c73ec3c12cd46ef4b5a57b85b3dd9907b32 /gnu/packages
parentaf63f03f27c8c4619c4edb9d3edb53e315c51cb4 (diff)
downloadpatches-4631e6c9cd83c07197175ac3483c49ee757e5916.tar
patches-4631e6c9cd83c07197175ac3483c49ee757e5916.tar.gz
gnu: tls: Use HTTPS for home pages where possible.
* gnu/packages/tls.scm (openssl, p11-kit, python-acme)[home-page]: Use HTTPS instead of HTTP, irony.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 7d5c85a314..b98420e25d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -140,7 +140,7 @@ in intelligent transportation networks.")
("libtasn1" ,libtasn1)))
(arguments
`(#:configure-flags '("--without-trust-paths")))
- (home-page "http://p11-glue.freedesktop.org/p11-kit.html")
+ (home-page "https://p11-glue.freedesktop.org/p11-kit.html")
(synopsis "PKCS#11 library")
(description
"p11-kit provides a way to load and enumerate PKCS#11 modules. It
@@ -396,7 +396,7 @@ required structures.")
(description
"OpenSSL is an implementation of SSL/TLS.")
(license license:openssl)
- (home-page "http://www.openssl.org/")))
+ (home-page "https://www.openssl.org/")))
;; Fixes CVE-2017-3735, CVE-2017-3736, CVE-2017-3737, and CVE-2017-3738.
;; See <https://www.openssl.org/news/cl102.txt>.
@@ -568,7 +568,7 @@ netcat implementation that supports TLS.")
("python-pyasn1" ,python-pyasn1)
("python-cryptography" ,python-cryptography)
("python-pyopenssl" ,python-pyopenssl)))
- (home-page "https://github.com/letsencrypt/letsencrypt")
+ (home-page "https://github.com/certbot/certbot")
(synopsis "ACME protocol implementation in Python")
(description "ACME protocol implementation in Python")
(license license:asl2.0)))