summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-03-13 21:11:48 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-03-13 21:11:48 +0100
commit80b58d15bc659d5d0b4565b9fa700eabfc38fd83 (patch)
tree1329bd33fe9ca30f955b4d0fb8e99c128636fdf2 /gnu/packages
parentebd43a2a45f9ac0ce702ef5810eddafd0830db5f (diff)
downloadpatches-80b58d15bc659d5d0b4565b9fa700eabfc38fd83.tar
patches-80b58d15bc659d5d0b4565b9fa700eabfc38fd83.tar.gz
gnu: Add python2-quex@0.67.3.
* gnu/packages/python.scm (python2-quex-0.67.3): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 22fbdf6720..2272f15b54 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12992,3 +12992,45 @@ filesystem events on Linux.")
(define-public python2-pyinotify
(package-with-python2 python-pyinotify))
+
+;; Ada parser uses this version.
+(define-public python2-quex-0.67.3
+ (package
+ (name "python2-quex")
+ (version "0.67.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/quex/HISTORY/0.67/quex-" version ".zip"))
+ (sha256
+ (base32
+ "14gv8ll3ipqv4kyc2xiy891nrmjl4ic823zfyx8hassagyclyppw"))
+ (file-name (string-append name "-" version ".zip"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (share/quex (string-append out "/share/quex"))
+ (bin (string-append out "/bin")))
+ (copy-recursively "." share/quex)
+ (mkdir-p bin)
+ (symlink (string-append share/quex "/quex-exe.py")
+ (string-append bin "/quex"))
+ #t))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "QUEX_PATH")
+ (files '("share/quex")))))
+ (home-page "http://quex.sourceforge.net/")
+ (synopsis "Lexical analyzer generator in Python")
+ (description "@code{quex} is a lexical analyzer generator in Python.")
+ (license license:lgpl2.1+))) ; Non-military