summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-20 19:03:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-20 20:18:07 +0100
commita50e03014177d2f00b5b85d3e1c295406f842016 (patch)
treeaba599d6c9792274f20fc772a23bb3ebdd047767 /gnu/packages
parentdb967b646292e3517fc11f98ea0d4c19fd2191a9 (diff)
downloadpatches-a50e03014177d2f00b5b85d3e1c295406f842016.tar
patches-a50e03014177d2f00b5b85d3e1c295406f842016.tar.gz
gnu: python-scipy, python-matplotlib: Fix build after Sphinx update.
* gnu/packages/python.scm (python-sphinx-1.2.3, python2-sphinx-1.2.3): New variables. (python-matplotlib)[native-inputs]: Change 'python-sphinx' to 'python-sphinx-1.2.3'. (python2-matplotlib)[native-inputs]: New field. (python-scipy)[native-inputs]: Change 'python-sphinx' to 'python-sphinx-1.2.3'. (python2-scipy)[native-inputs]: New field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 33 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 007c18206e..fd423d3112 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3016,6 +3016,24 @@ sources.")
(propagated-inputs `(("python2-pytz" ,python2-pytz)
,@(package-propagated-inputs base))))))
+;; This is needed for python-matplotlib@1.4 and python-scipy@0.16, at least.
+;; Try removing this when they are updated.
+(define-public python-sphinx-1.2.3
+ (package (inherit python-sphinx)
+ (version "1.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Sphinx" version))
+ (sha256
+ (base32
+ "011xizm3jnmf4cvs5i6kgf6c5nn046h79i8j0vd0f27yw9j3p4wl"))))
+ ;; XXX: "'NoneType' object has no attribute 'split'".
+ (arguments '(#:tests? #f))))
+
+(define-public python2-sphinx-1.2.3
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-sphinx-1.2.3)))))
+
(define-public python-sphinx-rtd-theme
(package
(name "python-sphinx-rtd-theme")
@@ -3747,7 +3765,7 @@ transcendental functions).")
("tk" ,tk)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python-sphinx" ,python-sphinx)
+ ("python-sphinx" ,python-sphinx-1.2.3)
("python-numpydoc" ,python-numpydoc)
("python-nose" ,python-nose)
("python-mock" ,python-mock)
@@ -3831,6 +3849,10 @@ toolkits.")
(package (inherit matplotlib)
;; Make sure to use special packages for Python 2 instead
;; of those automatically rewritten by package-with-python2.
+ (native-inputs
+ `(("python2-sphinx" ,python2-sphinx-1.2.3)
+ ,@(fold alist-delete (package-native-inputs matplotlib)
+ '("python-sphinx"))))
(propagated-inputs
`(("python2-pycairo" ,python2-pycairo)
("python2-pygobject-2" ,python2-pygobject-2)
@@ -3938,7 +3960,7 @@ functions.")
("openblas" ,openblas)))
(native-inputs
`(("python-nose" ,python-nose)
- ("python-sphinx" ,python-sphinx)
+ ("python-sphinx" ,python-sphinx-1.2.3)
("python-numpydoc" ,python-numpydoc)
("gfortran" ,gfortran)
("texlive" ,texlive)
@@ -4013,7 +4035,15 @@ routines such as routines for numerical integration and optimization.")
(license license:bsd-3)))
(define-public python2-scipy
- (package-with-python2 python-scipy))
+ (let ((scipy (package-with-python2
+ (strip-python2-variant python-scipy))))
+ (package (inherit scipy)
+ ;; Make sure to use special packages for Python 2 instead
+ ;; of those automatically rewritten by package-with-python2.
+ (native-inputs
+ `(("python2-sphinx" ,python2-sphinx-1.2.3)
+ ,@(fold alist-delete (package-native-inputs scipy)
+ '("python-sphinx")))))))
(define-public python-socksipy-branch
(package