summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-06-30 21:11:25 +0300
committerAlex Kost <alezost@gmail.com>2016-07-25 17:18:52 +0300
commite48e31bcc8c62fbd1caf77a1c4958fc49ab5ff7f (patch)
tree634a5c3223bd33d912c523db538c93b3cf5ae7ac /gnu/packages
parentf225ae75443d6f9e5741f26f953bbf832d341135 (diff)
downloadpatches-e48e31bcc8c62fbd1caf77a1c4958fc49ab5ff7f.tar
patches-e48e31bcc8c62fbd1caf77a1c4958fc49ab5ff7f.tar.gz
gnu: Add xfd.
* gnu/packages/xorg.scm (xfd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xorg.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index bc6692df1a..431c591315 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3917,6 +3917,52 @@ known to your X server, examine samples of each, and retrieve the X Logical
Font Description (XLFD) full name for a font.")
(license license:x11)))
+(define-public xfd
+ (package
+ (name "xfd")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/app/xfd-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0n97iqqap9wyxjan2n520vh4rrf5bc0apsw2k9py94dqzci258y1"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The same 'app-defaults' problem as with 'xfontsel' package.
+ (let ((app-defaults-dir "/share/X11/app-defaults"))
+ `(#:configure-flags
+ (list (string-append "--with-appdefaultdir="
+ %output ,app-defaults-dir))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-xfd
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/xfd")
+ `("XAPPLRESDIR" =
+ (,(string-append out ,app-defaults-dir)))))))))))
+ (inputs
+ `(("fontconfig" ,fontconfig)
+ ("libx11" ,libx11)
+ ("libxaw" ,libxaw)
+ ("libxft" ,libxft)
+ ("libxmu" ,libxmu)
+ ("libxrender" ,libxrender)))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://www.x.org/wiki/")
+ (synopsis "Display all the characters in an X font")
+ (description
+ "XFD (X Font Display) package provides an utility that displays a
+window containing the name of the font being displayed, a row of command
+buttons, several lines of text for displaying character metrics, and a grid
+containing one glyph per cell.")
+ (license license:x11)))
+
(define-public xmodmap
(package
(name "xmodmap")