summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:39:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:20 +0200
commitbb926860bf0a32bcca5e4a5c06a03affb0427c97 (patch)
tree123999cccb23c4a3fee3aa2261fa5822deaa94f6 /gnu/packages
parentf0d3638738549f2373a5ea7763e1a8be1a634901 (diff)
downloadpatches-bb926860bf0a32bcca5e4a5c06a03affb0427c97.tar
patches-bb926860bf0a32bcca5e4a5c06a03affb0427c97.tar.gz
gnu: emacs-helpful: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-helpful)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed1f70862a..f9e182d40b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10485,15 +10485,15 @@ downloading manager for Emacs.")
(package
(name "emacs-helpful")
(version "0.15")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Wilfred/helpful/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1xmvhphzb4hbg647dz4lafy6hd19b7bk3lxni6irqrzdsrclhzn6"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/helpful.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rqnx7672175288yqaslw0d9vw04j6psw7mys8j9zcp2i72hlvkn"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-elisp-refs" ,emacs-elisp-refs)))