summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-21 19:24:23 +0530
committerMarius Bakke <mbakke@fastmail.com>2017-03-21 15:42:44 +0100
commited428a58ec347a9fb48aa75d805fab665f0eb6f4 (patch)
tree5b5752b71fbb99482ad785ef39be4d51d080dd1b /gnu/packages
parent3411937b154dc424529e8129ad7d5f8318e70c56 (diff)
downloadpatches-ed428a58ec347a9fb48aa75d805fab665f0eb6f4.tar
patches-ed428a58ec347a9fb48aa75d805fab665f0eb6f4.tar.gz
gnu: Add swaks.
* gnu/packages/mail.scm (swaks): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm51
1 files changed, 50 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3bf0e66479..bd48176c7c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -2093,3 +2093,52 @@ indexed mbox files. There are two programs: @code{bindex} and @code{bit}.
are supported). @code{bit} is a CGI/SSI program that generates web pages
on the fly. Both programs are written in C and are very fast.")
(license license:expat)))
+
+(define-public swaks
+ (package
+ (name "swaks")
+ (version "20170101.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://jetmore.org/john/code/swaks/files/swaks-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0pli4mlhasnqqxmmxalwyg3x7n2vhcbgsnp2xgddamjavv82vrl4"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-net-dns" ,perl-net-dns)
+ ("perl-net-ssleay" ,perl-net-ssleay)))
+ (arguments
+ `(#:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (zero? (system* "pod2man" "doc/ref.pod" "swaks.1"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "swaks" (string-append out "/bin"))
+ (install-file "swaks.1" (string-append out "/share/man/man1")))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/swaks")
+ `("PERL5LIB" ":" = (,(getenv "PERL5LIB"))))
+ #t)))))
+ (home-page "http://jetmore.org/john/code/swaks/")
+ (synopsis "Featureful SMTP test tool")
+ (description "Swaks is a flexible, scriptable, transaction-oriented SMTP
+test tool. It handles SMTP features and extensions such as TLS,
+authentication, and pipelining; multiple versions of the SMTP protocol
+including SMTP, ESMTP, and LMTP; and multiple transport methods including
+unix-domain sockets, internet-domain sockets, and pipes to spawned processes.
+Options can be specified in environment variables, configuration files, and
+the command line allowing maximum configurability and ease of use for
+operators and scripters.")
+ (license gpl2+)))