summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 19:47:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 19:47:07 +0100
commit239716fb0ba0a7cd81f9d59dcf5a2261b8efe4fa (patch)
treeaf30ab635b2df74712caa054a67d0efec5264cf6 /gnu/packages
parent007a81d5cf3194bd96c7bacdd552d5708340d126 (diff)
downloadpatches-239716fb0ba0a7cd81f9d59dcf5a2261b8efe4fa.tar
patches-239716fb0ba0a7cd81f9d59dcf5a2261b8efe4fa.tar.gz
gnu: python-biom-format: Update to 2.1.7.
* gnu/packages/bioinformatics.scm (python-biom-format): Update to 2.1.7. [arguments]: Add phases "use-cython", "disable-broken-test", and "make-files-writable". [propagated-inputs]: Add python-flake8. [native-inputs]: Add python-cython, python-pytest, and python-pytest-cov.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 26 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 52f6af6504..e32bf60e66 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -691,7 +691,7 @@ Python.")
(define-public python-biom-format
(package
(name "python-biom-format")
- (version "2.1.6")
+ (version "2.1.7")
(source
(origin
(method git-fetch)
@@ -703,17 +703,40 @@ Python.")
(file-name (git-file-name name version))
(sha256
(base32
- "00yi8hkj3n7vdz8p8x93bi810f7cpm8rb0dd3kfhr2cpbmd2rsql"))))
+ "1rna16lyk5aqhnv0dp77wwaplias93f1vw28ad3jmyw6hwkai05v"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-cython
+ (lambda _ (setenv "USE_CYTHON" "1") #t))
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ (substitute* "biom/tests/test_cli/test_validate_table.py"
+ (("^(.+)def test_invalid_hdf5" m indent)
+ (string-append indent
+ "@npt.dec.skipif(True, msg='Guix')\n"
+ m)))
+ #t))
+ (add-before 'reset-gzip-timestamps 'make-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file) (chmod file #o644))
+ (find-files out "\\.gz"))
+ #t))))))
(propagated-inputs
`(("python-numpy" ,python-numpy)
("python-scipy" ,python-scipy)
+ ("python-flake8" ,python-flake8)
("python-future" ,python-future)
("python-click" ,python-click)
("python-h5py" ,python-h5py)
("python-pandas" ,python-pandas)))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-nose" ,python-nose)))
(home-page "http://www.biom-format.org")
(synopsis "Biological Observation Matrix (BIOM) format utilities")
(description