summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 16:02:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 16:31:52 +0100
commite02671939bcc4a38e13f68f58d4cb531150dde81 (patch)
tree6e18f5abd93b5c4a4345a3b4dd32685086dd0a42 /gnu/packages
parentceb831d33841d47f4b92c07829df9134853c83d0 (diff)
downloadpatches-e02671939bcc4a38e13f68f58d4cb531150dde81.tar
patches-e02671939bcc4a38e13f68f58d4cb531150dde81.tar.gz
gnu: acl: Update to 2.2.53.
* gnu/packages/patches/acl-hurd-path-max.patch, gnu/packages/patches/acl-fix-perl-regex.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/acl.scm (acl): Update to 2.2.53. [source](uri): Adjust for renamed tarball. [arguments]: Remove #:test-target. Adjust disabled tests. Don't override install phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/acl.scm24
-rw-r--r--gnu/packages/patches/acl-fix-perl-regex.patch22
-rw-r--r--gnu/packages/patches/acl-hurd-path-max.patch80
3 files changed, 10 insertions, 116 deletions
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index 8d5f0117f5..0131adcac4 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,21 +35,18 @@
(define-public acl
(package
(name "acl")
- (version "2.2.52")
+ (version "2.2.53")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/acl/acl-"
- version ".src.tar.gz"))
+ version ".tar.gz"))
(sha256
(base32
- "08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))
- (patches (search-patches "acl-fix-perl-regex.patch"
- "acl-hurd-path-max.patch"))))
+ "1ir6my3w74s6nfbgbqgzj6w570sn0qjf3524zx8xh67lqrjrigh6"))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "tests"
- #:modules ((ice-9 ftw)
+ `(#:modules ((ice-9 ftw)
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
@@ -75,13 +73,11 @@
(("\\| sed.*'") ""))
;; These tests require the existence of a user named "bin", but
;; this user does not exist within Guix's build environment.
- (for-each (lambda (file)
- (delete-file (string-append "test/" file)))
- '("setfacl-X.test" "cp.test" "misc.test"))
- #t))
- (replace 'install
- (lambda _
- (invoke "make" "install" "install-lib" "install-dev"))))))
+ (substitute* "Makefile.in"
+ ((".*test/misc\\.test.*") "")
+ ((".*test/cp\\.test.*") "")
+ ((".*test/setfacl-X\\.test.*") ""))
+ #t)))))
(inputs `(("attr" ,attr)))
(native-inputs
`(("gettext" ,gettext-minimal)
diff --git a/gnu/packages/patches/acl-fix-perl-regex.patch b/gnu/packages/patches/acl-fix-perl-regex.patch
deleted file mode 100644
index f682abc058..0000000000
--- a/gnu/packages/patches/acl-fix-perl-regex.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-This can be removed with the next acl release
-
----
- test/run | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/run b/test/run
-index 2cf52e8..4627cd2 100755
---- a/test/run
-+++ b/test/run
-@@ -70,7 +70,7 @@ for (;;) {
- if (defined $line) {
- # Substitute %VAR and %{VAR} with environment variables.
- $line =~ s[%(\w+)][$ENV{$1}]eg;
-- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
-+ $line =~ s[%\{(\w+)\}][$ENV{$1}]eg;
- }
- if (defined $line) {
- if ($line =~ s/^\s*< ?//) {
---
-2.15.0
-
diff --git a/gnu/packages/patches/acl-hurd-path-max.patch b/gnu/packages/patches/acl-hurd-path-max.patch
deleted file mode 100644
index 89cb3a38d7..0000000000
--- a/gnu/packages/patches/acl-hurd-path-max.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=636512
-
-From: Svante Signell <srs@kth.se>
-Subject: acl: Fix FTBFS on hurd-i386
-Date: Wed, 03 Aug 2011 19:36:27 +0200
-
-Currently acl does not compile on hurd-i386. The problem is a PATH_MAX
-definition which is not supported on GNU/Hurd.
-
-Index: acl-2.2.52/setfacl/parse.c
-===================================================================
---- acl-2.2.52/setfacl/parse.c
-+++ acl-2.2.52/setfacl/parse.c
-@@ -419,7 +419,13 @@ read_acl_comments(
- bytes for "# file: ". Not a good solution but for now it is the
- best I can do without too much impact on the code. [tw]
- */
-+
-+#ifdef __GNU__
-+ char *linebuf;
-+ size_t dummy = 0;
-+#else
- char linebuf[(4*PATH_MAX)+9];
-+#endif
- char *cp;
- char *p;
- int comments_read = 0;
-@@ -449,9 +455,13 @@ read_acl_comments(
- if (line)
- (*line)++;
-
-+#ifdef __GNU__
-+ if (getline(&linebuf, &dummy, file) == -1)
-+ break;
-+#else
- if (fgets(linebuf, sizeof(linebuf), file) == NULL)
- break;
--
-+#endif
- comments_read = 1;
-
- p = strrchr(linebuf, '\0');
-@@ -473,7 +483,12 @@ read_acl_comments(
- goto fail;
- *path_p = (char*)malloc(strlen(cp)+1);
- if (!*path_p)
-+ {
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return -1;
-+ }
- strcpy(*path_p, cp);
- }
- } else if (strncmp(cp, "owner:", 6) == 0) {
-@@ -522,13 +537,24 @@ read_acl_comments(
- }
- }
- if (ferror(file))
-+ {
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return -1;
-+ }
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return comments_read;
- fail:
- if (path_p && *path_p) {
- free(*path_p);
- *path_p = NULL;
- }
-+#ifdef __GNU__
-+ free (linebuf);
-+#endif
- return -EINVAL;
- }
-