summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAdam Van Ymeren <adam@vany.ca>2017-11-23 15:04:46 -0500
committerLudovic Courtès <ludo@gnu.org>2018-01-31 17:36:22 +0100
commit51f887f33d08a805fa62c726c81904ce54a540ac (patch)
treef703fdecff455ec89fc7f30befc25d9c45a9c7d7 /gnu/packages
parent8af20b997fababa24b639e9247729da6caaf3aee (diff)
downloadpatches-51f887f33d08a805fa62c726c81904ce54a540ac.tar
patches-51f887f33d08a805fa62c726c81904ce54a540ac.tar.gz
gnu: python-axolotl: Update to 0.1.39 and fix build.
python-axolotl has been failing since March, https://hydra.gnu.org/job/gnu/master/python-axolotl-0.1.35.x86_64-linux This also fixes the OMEMO and OTR plugins for Gajim work. * gnu/packages/patches/python-axolotl-AES-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python-crypto.scm (python-axolotl): Upgrade to 0.1.39. [source]: Use the patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/python-axolotl-AES-fix.patch24
-rw-r--r--gnu/packages/python-crypto.scm5
2 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/patches/python-axolotl-AES-fix.patch b/gnu/packages/patches/python-axolotl-AES-fix.patch
new file mode 100644
index 0000000000..d34f4855cb
--- /dev/null
+++ b/gnu/packages/patches/python-axolotl-AES-fix.patch
@@ -0,0 +1,24 @@
+Patch taken from the Debian package for python-axolotl-0.1.39.
+See <https://bugs.gnu.org/29415>.
+
+Description: Removes IV paramenter from AES constructor, since it is not necessary for ctr mode.
+Author: Josue Ortega <josue@debian.org>
+Last-Update: 2017-04-13
+
+--- a/axolotl/sessioncipher.py
++++ b/axolotl/sessioncipher.py
+@@ -228,13 +228,7 @@
+ # counterint = struct.unpack(">L", counterbytes)[0]
+ # counterint = int.from_bytes(counterbytes, byteorder='big')
+ ctr = Counter.new(128, initial_value=counter)
+-
+- # cipher = AES.new(key, AES.MODE_CTR, counter=ctr)
+- ivBytes = bytearray(16)
+- ByteUtil.intToByteArray(ivBytes, 0, counter)
+-
+- cipher = AES.new(key, AES.MODE_CTR, IV=bytes(ivBytes), counter=ctr)
+-
++ cipher = AES.new(key, AES.MODE_CTR, counter=ctr)
+ return cipher
+
+
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 7b0054cf8a..a9059efa5f 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -450,7 +450,7 @@ python-axolotl.")
(define-public python-axolotl
(package
(name "python-axolotl")
- (version "0.1.35")
+ (version "0.1.39")
(source
(origin
(method url-fetch)
@@ -458,8 +458,9 @@ python-axolotl.")
"https://github.com/tgalal/python-axolotl/archive/"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
+ (patches (search-patches "python-axolotl-AES-fix.patch"))
(sha256
- (base32 "1z8d89p7v40p4bwywjm9h4z28fdvra79ddw06azlkrfjbl7dxmz8"))))
+ (base32 "0badsgkgz0ir3hqynxzsfjgacppi874syvvmgccc6j164053x6zm"))))
(build-system python-build-system)
(arguments
`(#:phases