summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:22:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:06 +0200
commitb625752d03a78afc99eeca4299dc547bf5982449 (patch)
tree08e2054dfa56a1a89845c13381d6079235221701 /gnu/packages
parent3abaae5708da768cb8ce8fee0bc3d3851da9b886 (diff)
downloadpatches-b625752d03a78afc99eeca4299dc547bf5982449.tar
patches-b625752d03a78afc99eeca4299dc547bf5982449.tar.gz
gnu: emacs-helm-projectile: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-helm-projectile)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6378099125..1ba61a3d46 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5350,16 +5350,15 @@ for search-based navigation of buffers.")
(package
(name "emacs-helm-projectile")
(version "0.14.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/bbatsov/helm-projectile/archive/v"
- version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "19cfmilqh8kbab3b2hmx6lyrj73q6vfmn3p730x95g23iz16mnd5"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bbatsov/helm-projectile.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lph38p112fridighqcizpsyzjbv7qr3d8prbfj6w6q6gfl6cna4"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)