summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-13 13:01:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-13 13:04:18 +0100
commit14bba460abe1704ef7c02fb144c047ca0c8b821f (patch)
tree78e92e4074363bb98bf06b805c8472f5d7f0cd31 /gnu/packages
parent7097c7009deae1a1b4997e5222fd72b0c6c330f4 (diff)
downloadpatches-14bba460abe1704ef7c02fb144c047ca0c8b821f.tar
patches-14bba460abe1704ef7c02fb144c047ca0c8b821f.tar.gz
gnu: r-biocgenerics: Move to bioconductor.
* gnu/packages/bioinformatics.scm (r-biocgenerics): Move from here... * gnu/packages/bioconductor.scm (r-biocgenerics): ...to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm20
-rw-r--r--gnu/packages/bioinformatics.scm20
2 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 22d8b5320b..20aabb0be4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -228,6 +228,26 @@ database is exposed as a @code{TxDb} object.")
(license license:artistic2.0)))
+(define-public r-biocgenerics
+ (package
+ (name "r-biocgenerics")
+ (version "0.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BiocGenerics" version))
+ (sha256
+ (base32
+ "0cvpsrhg7sn7lpqgxvqrsagv6j7xj5rafq5xdjfd8zc4gxrs5rb8"))))
+ (properties
+ `((upstream-name . "BiocGenerics")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/BiocGenerics")
+ (synopsis "S4 generic functions for Bioconductor")
+ (description
+ "This package provides S4 generic functions needed by many Bioconductor
+packages.")
+ (license license:artistic2.0)))
+
(define-public r-annotate
(package
(name "r-annotate")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4012b472ae..b0af9b4d65 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7035,26 +7035,6 @@ use multiple corrections. Visualization of data can be done either by
barplots or heatmaps.")
(license license:gpl2+)))
-(define-public r-biocgenerics
- (package
- (name "r-biocgenerics")
- (version "0.28.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "BiocGenerics" version))
- (sha256
- (base32
- "0cvpsrhg7sn7lpqgxvqrsagv6j7xj5rafq5xdjfd8zc4gxrs5rb8"))))
- (properties
- `((upstream-name . "BiocGenerics")))
- (build-system r-build-system)
- (home-page "https://bioconductor.org/packages/BiocGenerics")
- (synopsis "S4 generic functions for Bioconductor")
- (description
- "This package provides S4 generic functions needed by many Bioconductor
-packages.")
- (license license:artistic2.0)))
-
(define-public r-biocinstaller
(package
(name "r-biocinstaller")