summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-15 18:18:38 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-15 18:18:38 +0200
commita1d1703a1dc6bfcd10f48fe707ee7ac65300a37d (patch)
tree57747826d4296aeda30e5506e6f076a1b51fa451 /gnu/packages
parentc43626131222b7b62d8cb6f5fe90c072d440df26 (diff)
downloadpatches-a1d1703a1dc6bfcd10f48fe707ee7ac65300a37d.tar
patches-a1d1703a1dc6bfcd10f48fe707ee7ac65300a37d.tar.gz
gnu: orc: Fix broken header file.
* gnu/packages/patches/orc-typedef-enum.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gstreamer.scm (orc)[source](patches): New field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gstreamer.scm1
-rw-r--r--gnu/packages/patches/orc-typedef-enum.patch17
2 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0d951009da..51b9d8f11c 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -74,6 +74,7 @@
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
+ (patches (search-patches "orc-typedef-enum.patch"))
(sha256
(base32
"0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
diff --git a/gnu/packages/patches/orc-typedef-enum.patch b/gnu/packages/patches/orc-typedef-enum.patch
new file mode 100644
index 0000000000..207bf32ba9
--- /dev/null
+++ b/gnu/packages/patches/orc-typedef-enum.patch
@@ -0,0 +1,17 @@
+Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
+
+Taken from upstream:
+https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
+
+diff --git a/orc/orctarget.h b/orc/orctarget.h
+--- a/orc/orctarget.h
++++ b/orc/orctarget.h
+@@ -19,7 +19,7 @@ enum {
+ ORC_TARGET_FAST_DENORMAL = (1<<31)
+ };
+
+-enum {
++typedef enum {
+ ORC_TARGET_POWERPC_64BIT = (1<<0),
+ ORC_TARGET_POWERPC_LE = (1<<1),
+ ORC_TARGET_POWERPC_ALTIVEC = (1<<2),