summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2017-12-05 23:27:23 +0300
committerAlex Kost <alezost@gmail.com>2017-12-10 22:38:43 +0300
commit6d21272b22d1303908639fc926c70c7145e95563 (patch)
tree9c46f66a053aac65b57096746896d5c023332f1c /gnu/packages
parent0f4ab4a59f4a8955135c7579c3579b8656e4060a (diff)
downloadpatches-6d21272b22d1303908639fc926c70c7145e95563.tar
patches-6d21272b22d1303908639fc926c70c7145e95563.tar.gz
gnu: git-modes: Rename to 'emacs-git-modes'.
* gnu/packages/emacs.scm (git-modes)[name]: Change to "emacs-git-modes". (git-modes/old-name): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 77da8f2f25..d08246f484 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -377,7 +377,7 @@ when typing parentheses directly or commenting out code line by line.")
(define-public git-modes
(package
- (name "git-modes")
+ (name "emacs-git-modes")
(version "1.2.6")
(source (origin
(method url-fetch)
@@ -396,6 +396,9 @@ when typing parentheses directly or commenting out code line by line.")
configuration files, such as .gitattributes, .gitignore, and .git/config.")
(license license:gpl3+)))
+(define-public git-modes/old-name
+ (deprecated-package "git-modes" git-modes))
+
(define-public emacs-with-editor
(package
(name "emacs-with-editor")