summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-01 22:33:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-22 18:58:06 +0100
commit0223db58ef36dbc552f91e12d2bb6e444bcfd7f6 (patch)
tree87f4bce5d2cb98b87bafca64e94f9c7c4d401714 /gnu/packages
parent759ad0690b4bfbe8b88cda8224d66954aad4cf5a (diff)
downloadpatches-0223db58ef36dbc552f91e12d2bb6e444bcfd7f6.tar
patches-0223db58ef36dbc552f91e12d2bb6e444bcfd7f6.tar.gz
gnu: util-linux: Don't build 'nologin'.
* gnu/packages/linux.scm (util-linux)[source](snippet): Add substitution.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1e00b1c7b0..95c609201c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -560,10 +560,11 @@ providing the system administrator with some help in common tasks.")
"util-linux-CVE-2018-7738.patch"))
(modules '((guix build utils)))
(snippet
- ;; We take the 'logger' program from GNU Inetutils and 'kill'
- ;; from GNU Coreutils.
+ ;; We take 'nologin' from Shadow, the 'logger' program from
+ ;; GNU Inetutils and 'kill' from GNU Coreutils.
'(begin
(substitute* "configure"
+ (("build_nologin=yes") "build_nologin=no")
(("build_logger=yes") "build_logger=no")
(("build_kill=yes") "build_kill=no"))
#t))))