summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-12-11 23:23:30 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-12-11 23:23:30 +0100
commit6ffb0b4f6a99f6f1d601418af6e87566957c0031 (patch)
tree839d05b9d96e2d7db4a4f64863fa703ed76b19b4 /gnu/packages
parent27664ea0f08e6c207b7b61c1fd7b8446dce98478 (diff)
downloadpatches-6ffb0b4f6a99f6f1d601418af6e87566957c0031.tar
patches-6ffb0b4f6a99f6f1d601418af6e87566957c0031.tar.gz
gnu: Add emacs-modus-themes.
* gnu/packages/emacs-xyz.scm (emacs-modus-themes): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7da8b9556..1a49ff4172 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19816,6 +19816,33 @@ Emacs that integrate with major modes like Org-mode.")
(home-page "https://github.com/hlissner/emacs-doom-themes")
(license license:expat)))
+(define-public emacs-modus-themes
+ (package
+ (name "emacs-modus-themes")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/modus-themes.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15g63675c5df2p0kk2sqj2c8qriyh69lcbggknqlaxapr13giz4x"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/protesilaos/modus-themes")
+ (synopsis "Emacs themes designed for colour-contrast accessibility")
+ (description
+ "This is a set of accessible themes for GNU Emacs. The contrast ratio
+between foreground and background values should always be >= 7:1, which
+conforms with the WCAG AAA accessibility standard.
+
+The Modus themes project consists of two standalone items, one where dark text
+is cast on a light backdrop (Modus Operandi) and another where light text is
+displayed against a dark background (Modus Vivendi).")
+ (license license:gpl3+)))
+
(define-public emacs-elixir-mode
(package
(name "emacs-elixir-mode")