summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-06-02 09:20:27 +0200
committerLeo Famulari <leo@famulari.name>2017-06-02 12:02:37 -0400
commit1eacffb9bc877c5568a3a1640b00e0b2e5b423e2 (patch)
treefe44910cb3c18328020d3159087a35602be7e90d /gnu/packages
parent466073c0638208d7f67c0e9e48144cae3bc3e94d (diff)
downloadpatches-1eacffb9bc877c5568a3a1640b00e0b2e5b423e2.tar
patches-1eacffb9bc877c5568a3a1640b00e0b2e5b423e2.tar.gz
gnu: Add archivemount
* gnu/packages/linux.scm (archivemount): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 13e08dcfaf..cad5a07f88 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages attr)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
@@ -1605,6 +1607,31 @@ up: on the server side there's nothing to do; on the client side mounting the
file system is as easy as logging into the server with an SSH client.")
(license license:gpl2+)))
+(define-public archivemount
+ (package
+ (name "archivemount")
+ (version "0.8.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.cybernoia.de/software/archivemount/"
+ "archivemount-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1diiw6pnlnrnikn6l5ld92dx59lhrxjlqms8885vwbynsjl5q127"))))
+ (build-system gnu-build-system)
+ (inputs `(("fuse", fuse)
+ ("libarchive", libarchive)))
+ (native-inputs `(("pkg-config", pkg-config)))
+ (home-page "http://www.cybernoia.de/software/archivemount")
+ (synopsis "Tool for mounting archive files with FUSE")
+ (description "archivemount is a FUSE-based file system for Unix variants,
+including Linux. Its purpose is to mount archives (i.e. tar, tar.gz, etc.) to a
+mount point where it can be read from or written to as with any other file
+system. This makes accessing the contents of the archive, which may be
+compressed, transparent to other programs, without decompressing them.")
+ (license license:lgpl2.0+)))
+
(define-public numactl
(package
(name "numactl")