summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-02 00:11:11 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-02 00:12:20 +0100
commit2a1f3e3f0f6bd4731f8e7cc98299342e5e9a2443 (patch)
treed2f562d88cf874801c0d074af7f4eea46f112062 /gnu/packages
parent27727b18b8597f7c6fd99adc7797c555aa1c92e9 (diff)
downloadpatches-2a1f3e3f0f6bd4731f8e7cc98299342e5e9a2443.tar
patches-2a1f3e3f0f6bd4731f8e7cc98299342e5e9a2443.tar.gz
gnu: colord: Record the file name of the "sqlite3" command.
* gnu/packages/gnome.scm (colord)[arguments]: Add 'set-sqlite3-file-name' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 428fe1cd16..cd881b5b87 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3059,7 +3059,16 @@ keyboard shortcuts.")
(substitute* "rules/meson.build"
(("udev.get_pkgconfig_variable\\('udevdir'\\)")
(string-append "'" (assoc-ref outputs "out") "/lib/udev'")))
- #t)))))
+ #t))
+ (add-before 'configure 'set-sqlite3-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; "colormgr dump" works by invoking the "sqlite3" command.
+ ;; Record its absolute file name.
+ (let ((sqlite (assoc-ref inputs "sqlite")))
+ (substitute* "client/cd-util.c"
+ (("\"sqlite3\"")
+ (string-append "\"" sqlite "/bin/sqlite3\"")))
+ #t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-resources, etc.
("gobject-introspection" ,gobject-introspection)