summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-30 14:33:18 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-30 14:40:49 +0100
commite16acb5c9b523a34a77c7fcddb986cd6840ba24c (patch)
tree13b414d0c0bb9afcf5d3f9ca0b7a228e26fc5096 /gnu/packages
parentd8bb1097d764949e80f9e41d26b3b194163dd716 (diff)
downloadpatches-e16acb5c9b523a34a77c7fcddb986cd6840ba24c.tar
patches-e16acb5c9b523a34a77c7fcddb986cd6840ba24c.tar.gz
gnu: Add emacs-eshell-prompt-extras.
* gnu/packages/emacs-xyz.scm (emacs-eshell-prompt-extras): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1be819728f..6b586abfcc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19622,3 +19622,28 @@ minibuffer or an each area message).
The contents and aspect is controlled by the @code{minibuffer-line-format}
variable and the @code{minibuffer-line} face.")
(license license:gpl3+)))
+
+(define-public emacs-eshell-prompt-extras
+ (let ((commit "5a328e1b9112c7f31ce2da7cde340f96626546b6")
+ (revision "1"))
+ (package
+ (name "emacs-eshell-prompt-extras")
+ (version (git-version "0.96" revision commit))
+ (home-page "https://github.com/zwild/eshell-prompt-extras")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fwlvrzjygs12dcp89wy3rb3wa03mrvbzpmpvmz4x6dfpr7csznk"))))
+ (build-system emacs-build-system)
+ (synopsis "Display extra information and color for your Eshell prompt")
+ (description "This library displays various customizable elements for
+@code{eshell} prompts: remote user, remote host, python virtual environment
+info, git branch, git dirty info and git unpushed number. Multiple themes are
+available.")
+ (license license:gpl3+))))