summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-31 00:41:31 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-10-31 01:03:27 +0100
commit2ed626bf0d28df44328c1946cd69eb79a853c6e0 (patch)
treed747ed851afce516a2f41e5185aa0ff9f7fde496 /gnu/packages
parent4b889d3a7a66a37d6513754eae312003a53352cd (diff)
downloadpatches-2ed626bf0d28df44328c1946cd69eb79a853c6e0.tar
patches-2ed626bf0d28df44328c1946cd69eb79a853c6e0.tar.gz
gnu: pingus: Adjust for GCC 7.
Fixes <https://bugs.gnu.org/37946>. * gnu/packages/games.scm (pingus)[source](modules, snippet): New fields.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 04b06c88ee..a2917a5f23 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1445,7 +1445,16 @@ fight Morgoth, the Lord of Darkness.")
(base32
"0wp06kcmknsnxz7bjnsndb8x062z7r23fb3yrnbfnj68qhz18y74"))
(patches (search-patches "pingus-boost-headers.patch"
- "pingus-sdl-libs-config.patch"))))
+ "pingus-sdl-libs-config.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "src/pingus/screens/demo_session.cpp"
+ (("#include <iostream>")
+ ;; std::function moved to <functional> with C++ 11.
+ ;; Remove this for versions newer than 0.7.6.
+ "#include <iostream>\n#include <functional>"))
+ #t))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("scons-python2" ,scons-python2)))