summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-08 19:17:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:42 +0200
commite68c70917958aa38c35a3cf349cdc80df31d2194 (patch)
tree28b5d285242987ca13b3d90e4c430cd111ae3946 /gnu/packages
parent5153431ca5ec9a27a5b1fe2374f8b1c58acb509e (diff)
downloadpatches-e68c70917958aa38c35a3cf349cdc80df31d2194.tar
patches-e68c70917958aa38c35a3cf349cdc80df31d2194.tar.gz
gnu: Add texlive-dehyph-exptl.
* gnu/packages/tex.scm (texlive-dehyph-exptl): New variable. (texlive-generic-dehyph-exptl): Deprecate.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm61
1 files changed, 25 insertions, 36 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9d26c9b156..74d8e04a75 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -529,42 +529,6 @@ to PostScript.")
license:expat
license:lgpl3+))))
-(define-public texlive-generic-dehyph-exptl
- (package
- (name "texlive-generic-dehyph-exptl")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/generic/dehyph-exptl"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "03yj1di9py92drp6gpfva6q69vk2iixr79r7cp7ja570s3pr0m33"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/generic/dehyph-exptl")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "http://projekte.dante.de/Trennmuster/WebHome")
- (synopsis "Hyphenation patterns for German")
- (description "The package provides experimental hyphenation patterns for
-the German language, covering both traditional and reformed orthography. The
-patterns can be used with packages Babel and hyphsubst from the Oberdiek
-bundle.")
- ;; Hyphenation patterns are under the Expat license; documentation is
- ;; under LPPL.
- (license (list license:expat license:lppl))))
-
(define-public texlive-generic-tex-ini-files
(package
(name "texlive-generic-tex-ini-files")
@@ -1609,6 +1573,31 @@ converters, will completely supplant the older patterns.")
(define-public texlive-generic-hyph-utf8
(deprecated-package "texlive-generic-hyph-utf8" texlive-hyph-utf8))
+(define-public texlive-dehyph-exptl
+ (package
+ (inherit (simple-texlive-package
+ "texlive-dehyph-exptl"
+ (list "/tex/generic/dehyph-exptl/"
+ "/doc/generic/dehyph-exptl/")
+ (base32
+ "1w2danvvy2f52hcb4acvjks53kcanwxr9s990fap6mj279hpgmh2")
+ #:trivial? #t))
+ (propagated-inputs
+ `(("texlive-hyphen-base" ,texlive-hyphen-base)
+ ("texlive-hyph-utf8" ,texlive-hyph-utf8)))
+ (home-page "http://projekte.dante.de/Trennmuster/WebHome")
+ (synopsis "Hyphenation patterns for German")
+ (description "The package provides experimental hyphenation patterns for
+the German language, covering both traditional and reformed orthography. The
+patterns can be used with packages Babel and hyphsubst from the Oberdiek
+bundle.")
+ ;; Hyphenation patterns are under the Expat license; documentation is
+ ;; under LPPL.
+ (license (list license:expat license:lppl))))
+
+(define-public texlive-generic-dehyph-exptl
+ (deprecated-package "texlive-generic-dehyph-exptl" texlive-dehyph-exptl))
+
(define-public texlive-latex-base
(let ((texlive-dir
(lambda (dir hash)