summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-09-26 23:15:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-10-03 18:52:18 +0200
commit6f2a2bd66d5f7e5e8d7d2fd6f6cfdf3e5006b567 (patch)
tree49163b7d7215de903f2f4a8ffc8e166157b8e3e5 /gnu/packages
parent43eb42ef017aa4752503fb2913781bb446716c1e (diff)
downloadpatches-6f2a2bd66d5f7e5e8d7d2fd6f6cfdf3e5006b567.tar
patches-6f2a2bd66d5f7e5e8d7d2fd6f6cfdf3e5006b567.tar.gz
gnu: Add emacs-all-the-icons.
* gnu/packages/emacs.scm (emacs-all-the-icons): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c10a80258e..b25358718c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12262,3 +12262,42 @@ execute its commands and resize images.")
(description "Synosaurus is a thesaurus fontend for Emacs with pluggable
backends, including the @command{wordnet} offline backend.")
(license license:gpl3+))))
+
+(define-public emacs-all-the-icons
+ (package
+ (name "emacs-all-the-icons")
+ (version "3.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/domtronn/all-the-icons.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sdl33117lccznj38021lwcdnpi9nxmym295q6y460y4dm4lx0jn"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include '("\\.el$" "^data/" "^fonts/")
+ ;; Compiling "test/" fails with "Symbol’s value as variable is void:
+ ;; all-the-icons--root-code". Ignoring tests.
+ #:exclude '("^test/")
+ #:tests? #f))
+ (propagated-inputs
+ `(("f" ,emacs-f)
+ ("memoize" ,emacs-memoize)))
+ (home-page "https://github.com/domtronn/all-the-icons.el")
+ (synopsis "Collect icon fonts and propertize them within Emacs")
+ (description "All-the-icons is a utility package to collect various icon
+fonts and propertize them within Emacs. Icon fonts allow you to propertize
+and format icons the same way you would normal text. This enables things such
+as better scaling of and anti aliasing of the icons.")
+ ;; Package is released under Expat license. Elisp files are licensed
+ ;; under GPL3+. Fonts come with various licenses: Expat for
+ ;; "all-the-icons.ttf" and "file-icons.ttf", Apache License 2.0 for
+ ;; "material-design-icons.ttf", and SIL OFL 1.1 for "fontawesome.ttf",
+ ;; "ocitcons.ttf" and "weathericons.ttf".
+ (license
+ (list license:expat license:gpl3+ license:silofl1.1 license:asl2.0))))
+