summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:41:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:21 +0200
commitd13cee982f58376b6770168708ba7fb8c585626e (patch)
treec21f3a3e59f67255fbf31f1e613ee4c8abcf5c19 /gnu/packages
parent6b746c89ac17088df946cd5a5483d6f282c40c52 (diff)
downloadpatches-d13cee982f58376b6770168708ba7fb8c585626e.tar
patches-d13cee982f58376b6770168708ba7fb8c585626e.tar.gz
gnu: emacs-dashboard: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-dashboard)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 54bd989478..00be4bcb9f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11238,14 +11238,13 @@ Emacs minor mode to escape sequences in code.")
(version "1.2.4")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/rakanalh/emacs-dashboard/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rakanalh/emacs-dashboard.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1738lmbgq6gk24hcwic0qjyajr21l5xzhya4pv58dw1bhd6vxv9g"))))
+ (base32 "1hhh1kfsz87qfmh45wjf2r93rz79rq0vbyxlfrsl02092zjbl1zr"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-page-break-lines" ,emacs-page-break-lines)))