summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-03 20:44:56 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-10 21:39:07 +0200
commitd1358ab6339b83ed84089f70d9ed4b55d860df07 (patch)
tree18cbfb69a3b7891e7181009d1b4cb497ef70a419 /gnu/packages
parent7b1c7ecdfbe26b56dbb19aa82874f3ef2df8ab08 (diff)
downloadpatches-d1358ab6339b83ed84089f70d9ed4b55d860df07.tar
patches-d1358ab6339b83ed84089f70d9ed4b55d860df07.tar.gz
gnu: Add ocaml-opam-file-format.
* gnu/packages/ocaml.scm (ocaml-opam-file-format): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7bebf3921b..3b98de3ed7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -302,6 +302,33 @@ functional, imperative and object-oriented styles of programming.")
for building OCaml library and programs.")
(license license:lgpl2.1+)))
+(define-public ocaml-opam-file-format
+ (package
+ (name "ocaml-opam-file-format")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/opam-file-format")
+ (commit version)))
+ (sha256
+ (base32
+ "0fqb99asnair0043hhc8r158d6krv5nzvymd0xwycr5y72yrp0hv"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:tests? #f; No tests
+ #:make-flags (list (string-append "LIBDIR=" (assoc-ref %outputs "out")
+ "/lib/ocaml/site-lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://opam.ocaml.org")
+ (synopsis "Parser and printer for the opam file syntax")
+ (description "This package contains a parser and a pretty-printer for
+the opam file fomat.")
+ ;; With static-linking exception
+ (license license:lgpl2.1+)))
+
(define-public opam
(package
(name "opam")