aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-31 01:47:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:51 +0200
commita0fd9a3ca9df2ea7d68c7e3e18cea16eac0fa48b (patch)
treecaea34a611780a7b5efece4a80836f4ccfb371f9 /gnu/packages
parenta6c6a59faf648f4fe23f40d362aff14d8bcd98af (diff)
downloadpatches-a0fd9a3ca9df2ea7d68c7e3e18cea16eac0fa48b.tar
patches-a0fd9a3ca9df2ea7d68c7e3e18cea16eac0fa48b.tar.gz
gnu: python-flake8: Update to 3.4.1.
* gnu/packages/python.scm (python-flake8): Update to 3.4.1. [source]: Remove obsolete snippet. [arguments]: Override 'check' phase. [propagated-inputs]: Remove PYTHON-PEP8. Add PYTHON-PYCODESTYLE and PYTHON-SETUPTOOLS. [native-inputs]: Change PYTHON-MOCK to PYTHON-MOCK-2. Remove PYTHON-NOSE. Add PYTHON-PYTEST-BOOTSTRAP and PYTHON-PYTEST-RUNNER. [properties]: Declare python2 variant. * gnu/packages/python.scm (python-flake8)[propagated-inputs]: Add PYTHON2-ENUM and PYTHON2-CONFIGPARSER.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm37
1 files changed, 23 insertions, 14 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 13943df45f..2023e8cc03 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7106,39 +7106,48 @@ complexity of Python source code.")
(define-public python-flake8
(package
(name "python-flake8")
- (version "2.5.4")
+ (version "3.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0bs9cz4fr99r2rwig1b8jwaadl1nan7kgpdzqwj0bwbckwbmh7nc"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove pre-compiled .pyc files from source.
- (for-each delete-file-recursively
- (find-files "." "__pycache__" #:directories? #t))
- (for-each delete-file (find-files "." "\\.pyc$"))
- #t))))
+ "1n0i38592vy3q0x2a9bf8z6rhhn04i30wsn5i5zzcj7qkxvl8062"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (zero? (system* "pytest" "-v")))))))
(propagated-inputs
- `(("python-pep8" ,python-pep8)
+ `(("python-pycodestyle" ,python-pycodestyle)
("python-pyflakes" ,python-pyflakes)
+ ;; flake8 depends on a newer setuptools than provided by python.
+ ("python-setuptools" ,python-setuptools)
("python-mccabe" ,python-mccabe)))
(native-inputs
- `(("python-mock" ,python-mock) ; TODO: only required for < 3.3
- ("python-nose" ,python-nose)))
+ `(("python-mock" ,python-mock-2) ; TODO: only required for < 3.3
+ ("python-pytest" ,python-pytest-bootstrap)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://gitlab.com/pycqa/flake8")
(synopsis
"The modular source code checker: pep8, pyflakes and co")
(description
"Flake8 is a wrapper around PyFlakes, pep8 and python-mccabe.")
+ (properties `((python2-variant . ,(delay python2-flake8))))
(license license:expat)))
(define-public python2-flake8
- (package-with-python2 python-flake8))
+ (let ((base (package-with-python2 (strip-python2-variant python-flake8))))
+ (package (inherit base)
+ (propagated-inputs
+ `(("python2-configparser" ,python2-configparser)
+ ("python2-enum" ,python2-enum)
+ ,@(package-propagated-inputs base))))))
(define-public python-flake8-polyfill
(package