summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:40:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:20 +0200
commit8792f08b098bb8f3778ea7339fcc4137e1fde60e (patch)
treea6467d2df1e7a6df8f243c457b191f01c5dff895 /gnu/packages
parent149829ee62ff494ea8c29917fc2adee83f0af482 (diff)
downloadpatches-8792f08b098bb8f3778ea7339fcc4137e1fde60e.tar
patches-8792f08b098bb8f3778ea7339fcc4137e1fde60e.tar.gz
gnu: emacs-visual-regexp: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-visual-regexp)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f1789a4897..573751b606 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10866,13 +10866,13 @@ decreasing the default font size in all GUI Emacs frames.")
(version "1.1.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/benma/visual-regexp.el/archive/"
- "v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benma/visual-regexp.el.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1czmhvcivlcdyz7rfm0vd4a3xsgmy4qbvbl6yjxc217wrxqflr92"))))
+ (base32 "12zpmzwyp85dzsjpxd3279kpfi9yz3jwc1k9fnb3xv3pjiil5svg"))))
(build-system emacs-build-system)
(home-page "https://github.com/benma/visual-regexp.el/")
(synopsis "Regexp command with interactive visual feedback")