summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-27 23:49:30 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-27 23:49:30 +0100
commit829ecd002e70682d11a22e26a7fe7e87248a8fec (patch)
tree0e44e654b30809882b2b1a7a9f5a67d23bb2bd3e /gnu/packages
parent3bb33e24bb495d78e6be663b5763245a1d63bc90 (diff)
parent65f7c35d02175806f676b8e130236dd3e6c8ec60 (diff)
downloadpatches-829ecd002e70682d11a22e26a7fe7e87248a8fec.tar
patches-829ecd002e70682d11a22e26a7fe7e87248a8fec.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/libwebsockets.scm
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnunet.scm4
-rw-r--r--gnu/packages/libwebsockets.scm73
-rw-r--r--gnu/packages/mpd.scm123
-rw-r--r--gnu/packages/parallel.scm4
-rw-r--r--gnu/packages/upnp.scm63
-rw-r--r--gnu/packages/video.scm4
-rw-r--r--gnu/packages/web.scm50
-rw-r--r--gnu/packages/zile.scm11
8 files changed, 249 insertions, 83 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 7f7a6fd6f9..3b111fd27c 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -105,14 +105,14 @@ tool to extract metadata from a file and print the results.")
(define-public libmicrohttpd
(package
(name "libmicrohttpd")
- (version "0.9.32")
+ (version "0.9.34")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libmicrohttpd/libmicrohttpd-"
version ".tar.gz"))
(sha256
(base32
- "176qf3xhpq1wa3fd9h8b6996bjf83yna1b30lhb6ccrv67hvhm75"))))
+ "122snbhhn10s8az46f0lrkirhj0k38lq7hmqav3n1prdzpabz8i9"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
diff --git a/gnu/packages/libwebsockets.scm b/gnu/packages/libwebsockets.scm
deleted file mode 100644
index 65aa174355..0000000000
--- a/gnu/packages/libwebsockets.scm
+++ /dev/null
@@ -1,73 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages libwebsockets)
- #:use-module (guix packages)
- #:use-module (guix git-download)
- #:use-module (guix build-system gnu)
- #:use-module ((guix licenses)
- #:select (lgpl2.1))
- #:use-module (gnu packages autotools)
- #:use-module ((gnu packages compression) #:select (zlib))
- #:use-module (gnu packages perl)
- #:use-module (gnu packages openssl))
-
-(define-public libwebsockets
- (package
- (name "libwebsockets")
- (version "1.2")
- (source (origin
- ;; The project does not publish tarballs, so we have to take
- ;; things from Git.
- (method git-fetch)
- (uri (git-reference
- (url "git://git.libwebsockets.org/libwebsockets")
- (commit (string-append "v" version
- "-chrome26-firefox18"))))
- (sha256
- (base32
- "1293hbz8qj4p27m1qjf8dn97r10xjyiwdpq491m87zi025s558cl"))
- (file-name (string-append name "-" version))))
-
- ;; The package has both CMake and GNU build systems, but the latter is
- ;; apparently better supported (CMake-generated makefiles lack an
- ;; 'install' target, for instance.)
- (build-system gnu-build-system)
-
- (arguments
- '(#:phases (alist-cons-before
- 'configure 'bootstrap
- (lambda _
- (chmod "libwebsockets-api-doc.html" #o666)
- (zero? (system* "./autogen.sh")))
- %standard-phases)))
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool "bin")
- ("perl" ,perl))) ; to build the HTML doc
- (inputs `(("zlib" ,zlib)
- ("openssl" ,openssl)))
- (synopsis "WebSockets library written in C")
- (description
- "libwebsockets is a library that allows C programs to establish client
-and server WebSockets connections---a protocol layered above HTTP that allows
-for efficient socket-like bidirectional reliable communication channels.")
- (home-page "http://libwebsockets.org/")
-
- ;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
- (license lgpl2.1)))
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
new file mode 100644
index 0000000000..b2c5dec15b
--- /dev/null
+++ b/gnu/packages/mpd.scm
@@ -0,0 +1,123 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mpd)
+ #:use-module (srfi srfi-1)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages avahi)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages mp3)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages sqlite)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xiph)
+ #:export (libmpdclient
+ mpd))
+
+(define libmpdclient
+ (package
+ (name "libmpdclient")
+ (version "2.9")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://musicpd.org/download/libmpdclient/"
+ (car (string-split version #\.))
+ "/libmpdclient-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0csb9r3nlmbwpiryixjr5k33x3zqd61xjhwmlps3a6prck1n1xw2"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; FIXME: Needs doxygen.
+ '(#:configure-flags '("--disable-documentation")))
+ (synopsis "Music Player Daemon client library")
+ (description "A stable, documented, asynchronous API library for
+interfacing MPD in the C, C++ & Objective C languages.")
+ (home-page "http://www.musicpd.org/libs/libmpdclient/")
+ (license license:bsd-3)))
+
+(define mpd
+ (package
+ (name "mpd")
+ (version "0.18.8")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://musicpd.org/download/mpd/"
+ (string-join (take (string-split
+ version #\.) 2) ".")
+ "/mpd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ryqh0xf76xv4mpwy1gjwy275ar4wmbzifa9ccjim9r7lk2hgp5v"))))
+ (build-system gnu-build-system)
+ (inputs `(("ao" ,ao)
+ ("alsa-lib" ,alsa-lib)
+ ("avahi" ,avahi)
+ ("curl" ,curl)
+ ("ffmpeg" ,ffmpeg)
+ ("flac" ,flac)
+ ("glib" ,glib)
+ ("lame" ,lame)
+ ("libid3tag" ,libid3tag)
+ ("libmad" ,libmad)
+ ("libmpdclient" ,libmpdclient)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("libvorbis" ,libvorbis)
+ ("opus" ,opus)
+ ("pkg-config" ,pkg-config)
+ ("pulseaudio" ,pulseaudio)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ ;; Missing optional inputs:
+ ;; libyajl
+ ;; libcdio_paranoia
+ ;; libmms
+ ;; libadplug
+ ;; libaudiofile
+ ;; faad2
+ ;; fluidsynth
+ ;; libgme
+ ;; libshout
+ ;; libmpg123
+ ;; libmodplug
+ ;; libmpcdec
+ ;; libsidplay2
+ ;; libwavpack
+ ;; libwildmidi
+ ;; libtwolame
+ ;; libroar
+ ;; libjack
+ ;; OpenAL
+ (synopsis "Music Player Daemon")
+ (description "Music Player Daemon (MPD) is a flexible, powerful,
+server-side application for playing music. Through plugins and libraries it
+can play a variety of sound files while being controlled by its network
+protocol.")
+ (home-page "http://www.musicpd.org/")
+ (license license:gpl2)))
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 684ef1821e..175b066113 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -27,7 +27,7 @@
(define-public parallel
(package
(name "parallel")
- (version "20140122")
+ (version "20140222")
(source
(origin
(method url-fetch)
@@ -35,7 +35,7 @@
version ".tar.bz2"))
(sha256
(base32
- "17y72p7qwr7n0qy9nzxwhcn3q47829fd0d69gql2x6szlsxkk0xi"))))
+ "0zb3hg92br6a53jn0pzfl16ffc1hfw81jk7nzw5spkshsdrcqx3y"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)))
(home-page "http://www.gnu.org/software/parallel/")
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
new file mode 100644
index 0000000000..a1a18d272c
--- /dev/null
+++ b/gnu/packages/upnp.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages upnp)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages))
+
+(define-public miniupnpc
+ (package
+ (name "miniupnpc")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://miniupnp.tuxfamily.org/files/miniupnpc-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0r24jdqcyf839n30ppimdna0hvybscyziaad7ng99fw0x19y88r9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("python" ,python-2)))
+ (arguments
+ ;; The build system does not use a configure script but depends on
+ ;; `make'. Hence we should pass parameters to `make' instead and remove
+ ;; the configure phase.
+ '(#:make-flags
+ (list
+ (string-append
+ "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
+ (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases
+ (alist-delete 'configure %standard-phases)))
+ (home-page "http://miniupnp.free.fr/")
+ (synopsis "Library implementing the client side UPnP protocol")
+ (description
+ "MiniUPnPc is a library is useful whenever an application needs to listen
+for incoming connections but is run behind a UPnP enabled router or firewall.
+Examples for such applications include: P2P applications, FTP clients for
+active mode, IRC (for DCC) or IM applications, network games, any server
+software.")
+ (license
+ (x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 369f29f7ac..ab5033eb73 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -35,14 +35,14 @@
(define-public ffmpeg
(package
(name "ffmpeg")
- (version "2.1.3")
+ (version "2.1.4")
(source (origin
(method url-fetch)
(uri (string-append "http://www.ffmpeg.org/releases/ffmpeg-"
version ".tar.bz2"))
(sha256
(base32
- "18qkdpka94rp44x17q7d2bvmw26spxf41c69nvzy31szsdzjwcqx"))))
+ "00c1k84amgkc7vk5xkrg7z99q7jbfhbz3qk854cxnc38d2ynrd3z"))))
(build-system gnu-build-system)
(inputs
`(("fontconfig" ,fontconfig)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 350781b74b..4eb39069db 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,9 +23,12 @@
#:renamer (symbol-prefix-proc 'l:))
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system perl)
#:use-module (guix build-system gnu)
#:use-module (gnu packages apr)
+ #:use-module (gnu packages autotools)
+ #:use-module ((gnu packages compression) #:select (zlib))
#:use-module (gnu packages openssl)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl))
@@ -66,6 +70,52 @@ related documentation.")
(license l:asl2.0)
(home-page "https://httpd.apache.org/")))
+(define-public libwebsockets
+ (package
+ (name "libwebsockets")
+ (version "1.2")
+ (source (origin
+ ;; The project does not publish tarballs, so we have to take
+ ;; things from Git.
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.libwebsockets.org/libwebsockets")
+ (commit (string-append "v" version
+ "-chrome26-firefox18"))))
+ (sha256
+ (base32
+ "1293hbz8qj4p27m1qjf8dn97r10xjyiwdpq491m87zi025s558cl"))
+ (file-name (string-append name "-" version))))
+
+ ;; The package has both CMake and GNU build systems, but the latter is
+ ;; apparently better supported (CMake-generated makefiles lack an
+ ;; 'install' target, for instance.)
+ (build-system gnu-build-system)
+
+ (arguments
+ '(#:phases (alist-cons-before
+ 'configure 'bootstrap
+ (lambda _
+ (chmod "libwebsockets-api-doc.html" #o666)
+ (zero? (system* "./autogen.sh")))
+ %standard-phases)))
+
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool "bin")
+ ("perl" ,perl))) ; to build the HTML doc
+ (inputs `(("zlib" ,zlib)
+ ("openssl" ,openssl)))
+ (synopsis "WebSockets library written in C")
+ (description
+ "libwebsockets is a library that allows C programs to establish client
+and server WebSockets connections---a protocol layered above HTTP that allows
+for efficient socket-like bidirectional reliable communication channels.")
+ (home-page "http://libwebsockets.org/")
+
+ ;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
+ (license l:lgpl2.1)))
+
(define-public perl-html-tagset
(package
(name "perl-html-tagset")
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index d9c66b4bc6..309344bcd6 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,19 +26,20 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages help2man)
#:use-module (gnu packages ncurses)
- #:use-module (gnu packages bash))
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages pkg-config))
(define-public zile
(package
(name "zile")
- (version "2.4.9")
+ (version "2.4.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/zile/zile-"
version ".tar.gz"))
(sha256
(base32
- "0j801c28ypm924rw3lqyb6khxyslg6ycrv16wmmwcam0mk3mj6f7"))))
+ "1ca2bkhl8k4n7a5d8g33ccs603p83a4h3vz9bwxcqxq43jjnwddn"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-before
@@ -55,7 +57,8 @@
("bash" ,bash)))
(native-inputs
`(("perl" ,perl)
- ("help2man" ,help2man)))
+ ("help2man" ,help2man)
+ ("pkg-config" ,pkg-config)))
(home-page "http://www.gnu.org/software/zile/")
(synopsis "Zile is lossy Emacs, a lightweight Emacs clone")
(description