summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-03 23:26:36 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-10 21:39:15 +0200
commit718fadb8cabcc4c6fb2574017c2bc071289733b0 (patch)
treea94bafea697fe5dcbdf92330da770337dcf3bc9f /gnu/packages
parentbb338a7f80645e33dd56bffd885eb2d487937715 (diff)
downloadpatches-718fadb8cabcc4c6fb2574017c2bc071289733b0.tar
patches-718fadb8cabcc4c6fb2574017c2bc071289733b0.tar.gz
gnu: Add ocaml-cudf.
* gnu/packages/ocaml.scm (ocaml-cudf): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 023f8efa69..263a318e58 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -329,6 +329,40 @@ for day to day programming.")
;; With static-linking exception
(license license:lgpl2.1+)))
+(define-public ocaml-cudf
+ (package
+ (name "ocaml-cudf")
+ (version "0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://gforge.inria.fr/frs/download.php/36602/cudf-0.9.tar.gz")
+ (sha256
+ (base32
+ "0771lwljqwwn3cryl0plny5a5dyyrj4z6bw66ha5n8yfbpcy8clr"))))
+ (build-system ocaml-build-system)
+ (propagated-inputs `(("ocaml-extlib" ,ocaml-extlib)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("ocamlbuild" ,ocamlbuild)
+ ("ocaml-ounit" ,ocaml-ounit)))
+ (arguments
+ `(#:make-flags
+ (list
+ "all" "opt"
+ (string-append "BINDIR=" (assoc-ref %outputs "out")
+ "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://www.mancoosi.org/cudf/")
+ (synopsis "CUDF library (part of the Mancoosi tools)")
+ (description "CUDF (for Common Upgradeability Description Format) is a
+format for describing upgrade scenarios in package-based Free and Open Source
+Software distribution.")
+ ;; With static-linking exception
+ (license license:lgpl2.1+)))
+
(define-public ocaml-opam-file-format
(package
(name "ocaml-opam-file-format")