summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-13 19:57:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-13 19:58:35 +0100
commit0efd09acd402e1d333e21df35fe64cb9ee8d6811 (patch)
tree729304e60b5f5bf84ec33fe8b6fa0edd5cbffee6 /gnu/packages
parent79f450a120068ac1d2fc4e5b4b33ae938b604f95 (diff)
downloadpatches-0efd09acd402e1d333e21df35fe64cb9ee8d6811.tar
patches-0efd09acd402e1d333e21df35fe64cb9ee8d6811.tar.gz
gnu: Add r-riverplot.
* gnu/packages/cran.scm (r-riverplot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9b690833ce..b7126518c1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3192,3 +3192,25 @@ data, commencing with a port of the Matlab gaussian window smoothing function.
In addition, several functions typically used in smoothing of financial data
are included.")
(license license:gpl2)))
+
+(define-public r-riverplot
+ (package
+ (name "r-riverplot")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "riverplot" version))
+ (sha256
+ (base32
+ "0q1icpny8nkxyjhawyjzwrw8qlz0ayn2xyrsqrm4vkxyv6c9xk8z"))))
+ (build-system r-build-system)
+ (home-page "https://logfc.wordpress.com")
+ (synopsis "Sankey or ribbon plots")
+ (description
+ "Sankey plots are a type of diagram that is convenient to illustrate how
+flow of information, resources etc. separates and joins, much like observing
+how rivers split and merge. For example, they can be used to compare
+different clusterings. This package provides an implementation of Sankey
+plots for R.")
+ (license license:gpl2+)))