summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-06 17:06:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-06 17:06:57 +0200
commit58e37b5441f548d2980fd3280547ad4b32ce7d44 (patch)
treedb84309ab4a94315fc6be77bda7e9db029e10ed7 /gnu/packages
parentc94884bcc1d762578077ccc84a7f45d87b38cd46 (diff)
downloadpatches-58e37b5441f548d2980fd3280547ad4b32ce7d44.tar
patches-58e37b5441f548d2980fd3280547ad4b32ce7d44.tar.gz
gnu: nss: Fix build failure on armhf-linux.
Fixes <https://bugs.gnu.org/36930>. * gnu/packages/patches/nss-freebl-stubs.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/nss.scm (nss)[source](patches): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/nss.scm1
-rw-r--r--gnu/packages/patches/nss-freebl-stubs.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 9a77f2f9ba..b6df366a77 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -84,6 +84,7 @@ in the Mozilla clients.")
"12sfq9xvpwpc22qnjsg1if1lmchiy33byrh92wn91phz7li0abqi"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
+ "nss-freebl-stubs.patch"
"nss-increase-test-timeout.patch"))))
(build-system gnu-build-system)
(outputs '("out" "bin"))
diff --git a/gnu/packages/patches/nss-freebl-stubs.patch b/gnu/packages/patches/nss-freebl-stubs.patch
new file mode 100644
index 0000000000..3f7b47b029
--- /dev/null
+++ b/gnu/packages/patches/nss-freebl-stubs.patch
@@ -0,0 +1,20 @@
+This patch is required for Makefile-based builds of NSS 3.45 on armhf-linux.
+
+Taken from upstream bug tracker:
+https://bugzilla.mozilla.org/show_bug.cgi?id=1571316
+
+diff --git a/nss/lib/freebl/ecl/curve25519_32.c b/nss/lib/freebl/ecl/curve25519_32.c
+--- a/nss/lib/freebl/ecl/curve25519_32.c
++++ b/nss/lib/freebl/ecl/curve25519_32.c
+@@ -29,6 +29,10 @@
+ * 1. Convert custom integer types to stdint.h types
+ */
+
++#ifdef FREEBL_NO_DEPEND
++#include "../stubs.h"
++#endif
++
+ #include "ecl-priv.h"
+
+ /* fe means field element. Here the field is \Z/(2^255-19). An element t,
+