summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 07:34:57 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 10:43:25 +1000
commitd5eca4f9ac8d7000e53136379def8ce6ec561718 (patch)
treef75f615c17df8da2e6eb4fd710738bcd6dc3e4b4 /gnu/packages
parenta2fa9c3d1baf65cc5aec2ce843e2d7921e593c21 (diff)
downloadpatches-d5eca4f9ac8d7000e53136379def8ce6ec561718.tar
patches-d5eca4f9ac8d7000e53136379def8ce6ec561718.tar.gz
gnu: Add r-diptest.
* gnu/packages/statistics.scm (r-diptest): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e02c342c6f..7282c3cf8f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4169,3 +4169,23 @@ perform @dfn{independent component analysis} (ICA) and projection pursuit.")
"This package provides the Breiman and Cutler's random forests algorithm, based on a
forest of trees using random inputs, for classification and regression.")
(license license:gpl2+)))
+
+(define-public r-diptest
+ (package
+ (name "r-diptest")
+ (version "0.75-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "diptest" version))
+ (sha256
+ (base32
+ "06xnc5gv1284ll0addxnxb6ljz6fn8dbyrp5vchyz6551h800aa6"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/diptest")
+ (synopsis "Hartigan's dip test statistic for unimodality")
+ (description
+ "This package computes Hartigan's dip test statistic for unimodality,
+multimodality and provides a test with simulation based p-values, where the
+original public code has been corrected.")
+ (license license:gpl2+)))