summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 13:32:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:58 +0100
commitc71724653ab2b75ef533e9b9920e7b3f735154ad (patch)
treec7793e77276dbbd51160cb486b574d279212b1bc /gnu/packages
parentccc2c19b02ef2a5b71ea67719a0d57b34e2622b7 (diff)
downloadpatches-c71724653ab2b75ef533e9b9920e7b3f735154ad.tar
patches-c71724653ab2b75ef533e9b9920e7b3f735154ad.tar.gz
gnu: Add r-shapes.
* gnu/packages/cran.scm (r-shapes): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dbaf4f88af..6ef9f2e680 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18563,3 +18563,32 @@ spherical depths are supported.")
archetypal analysis supporting arbitrary problem solving mechanisms for the
different conceptual parts of the algorithm.")
(license license:gpl2+)))
+
+(define-public r-shapes
+ (package
+ (name "r-shapes")
+ (version "1.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shapes" version))
+ (sha256
+ (base32
+ "0gfpdydfysp5mwg7qmkn73s67gvh2szb40mzqrx97h41ijgcgd8s"))))
+ (properties `((upstream-name . "shapes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-minpack-lm" ,r-minpack-lm)
+ ("r-rgl" ,r-rgl)
+ ("r-scatterplot3d" ,r-scatterplot3d)))
+ (home-page "http://www.maths.nottingham.ac.uk/~ild/shapes")
+ (synopsis "Statistical shape analysis")
+ (description
+ "This package provides routines for the statistical analysis of landmark
+shapes, including Procrustes analysis, graphical displays, principal
+components analysis, permutation and bootstrap tests, thin-plate spline
+transformation grids and comparing covariance matrices. See Dryden, I.L. and
+Mardia, K.V. (2016). Statistical shape analysis, with Applications in R (2nd
+Edition), John Wiley and Sons.")
+ (license license:gpl2)))