summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:11:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:55 +0100
commitc3f5989c8f92de1693610c5237e0794991d7534d (patch)
tree03353d3d555dd9fecaef645bd8c3966d221e502a /gnu/packages
parent3bc2c210431720d75c3a0eb786d4b4ff14a19061 (diff)
downloadpatches-c3f5989c8f92de1693610c5237e0794991d7534d.tar
patches-c3f5989c8f92de1693610c5237e0794991d7534d.tar.gz
gnu: Add r-treeclust.
* gnu/packages/cran.scm (r-treeclust): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d3db6b0ca4..6dd36c36ce 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17591,3 +17591,27 @@ classes into dummy/indicator variables.")
modeling often used in @dfn{analytical customer relationship
management} (aCRM).")
(license license:gpl2+)))
+
+(define-public r-treeclust
+ (package
+ (name "r-treeclust")
+ (version "1.1-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "treeClust" version))
+ (sha256
+ (base32
+ "1s7kh6q0bkixsygrip95zf1bi10ihddsa5lq9dfxd68yh8rsby6z"))))
+ (properties `((upstream-name . "treeClust")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)
+ ("r-rpart" ,r-rpart)))
+ (home-page "https://cran.r-project.org/web/packages/treeClust/")
+ (synopsis "Cluster distances through trees")
+ (description
+ "This package provides tools to create a measure of inter-point
+dissimilarity useful for clustering mixed data, and, optionally, perform the
+clustering.")
+ (license license:gpl2+)))