summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 09:56:57 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 10:43:26 +1000
commitc0cab38e037e67e3b9c784270b846687b749b27f (patch)
treeae2a6a67e704dc09ad85271da0beabf18d62ab7d /gnu/packages
parentcda0720805b31c6fd2e3d0b6ffa0a4294429428f (diff)
downloadpatches-c0cab38e037e67e3b9c784270b846687b749b27f.tar
patches-c0cab38e037e67e3b9c784270b846687b749b27f.tar.gz
gnu: Add r-robustbase.
* gnu/packages/statistics.scm (r-robustbase): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6714b765f4..c9eddff259 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4302,3 +4302,26 @@ The aim is to curate a collection of its state-of-the-art variants that (1) do
not sacrifice simplicity of design, (2) are essentially tuning-free, and (3)
can be efficiently implemented directly in the R language.")
(license license:gpl2+)))
+
+(define-public r-robustbase
+ (package
+ (name "r-robustbase")
+ (version "0.92-7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "robustbase" version))
+ (sha256
+ (base32
+ "13xz4am7y0s0kl5bmbcw3dlhl7ji8h9sjx56wsgmj6r9n35nrggw"))))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (propagated-inputs
+ `(("r-deoptimr" ,r-deoptimr)))
+ (home-page "http://robustbase.r-forge.r-project.org/")
+ (synopsis "Basic robust statistics")
+ (description
+ "This packages allows to analyze data with robust methods such as
+regression methodology including model selections and multivariate statistics.")
+ (license license:gpl2+)))