summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-02 14:33:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-02 14:45:52 +0200
commit8ef3f2e3ac54f2c7b41ac76d4e61a16436332d2f (patch)
treef571fcce8192d3daf1214c658369150bdf7dfcfc /gnu/packages
parent359a57b6e12aac05847c1dbee397a16c7b1d9559 (diff)
downloadpatches-8ef3f2e3ac54f2c7b41ac76d4e61a16436332d2f.tar
patches-8ef3f2e3ac54f2c7b41ac76d4e61a16436332d2f.tar.gz
gnu: alex4: Update to 1.2.1.
* gnu/packages/games.scm (alex4): Update to 1.2.1. [arguments]: Use top-level Makefile. Drop DATADIR. Remove ’configure’ phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 67395e6e12..844f9cab68 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -253,7 +253,7 @@ mouse and joystick control, and original music.")
(define-public alex4
(package
(name "alex4")
- (version "1.2-alpha")
+ (version "1.2.1")
(source
(origin
(method git-fetch)
@@ -262,27 +262,17 @@ mouse and joystick control, and original music.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "104nlhdsv1sg9g08fh5adwazw80400081awy7jsrn842srca0q1f"))))
+ (base32 "098wy72mh4lsvq3gm0rhamjssf9l1hp6hhkpzrv7klpb97cwwc3h"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
#:make-flags
- (list "-Csrc"
- "CC=gcc"
+ (list "CC=gcc"
"CFLAGS=-D_FILE_OFFSET_BITS=64"
- (string-append "DATADIR=" (assoc-ref %outputs "out")
- "/share/" ,name)
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (substitute* '("src/main.c"
- "src/shooter.c")
- (("fcos") "fixcos")
- (("fmul") "fixmul")
- (("fsin") "fixsin"))
- #t))
+ (delete 'configure) ; no configure script
(add-after 'install 'install-data
(lambda* (#:key outputs #:allow-other-keys)
(let ((share (string-append (assoc-ref outputs "out")