summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-09-08 12:07:09 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-09-26 17:18:22 +0200
commit8581b40d097bf7c0b3016435e0985cf56a003afb (patch)
tree2f5af965e10482c4a8031274bc8fcb307a20676b /gnu/packages
parent2ea4587d8373bce140f24bf2b9219cd73c378f8b (diff)
downloadpatches-8581b40d097bf7c0b3016435e0985cf56a003afb.tar
patches-8581b40d097bf7c0b3016435e0985cf56a003afb.tar.gz
gnu: Add python-distro.
* gnu/packages/python-xyz.scm (python-distro): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 69c8e63ecf..1bd218b797 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
-;;; Copyright © 2016, 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2018-2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
@@ -16398,3 +16398,30 @@ because lxml.etree already has it's own implementation of XPath 1.0.")
(synopsis "Python library to parse BibTeX files")
(description "BibtexParser is a Python library to parse BibTeX files.")
(license (list license:bsd-3 license:lgpl3))))
+
+(define-public python-distro
+ (package
+ (name "python-distro")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "distro" version))
+ (sha256
+ (base32
+ "0mrg75w4ap7mdzyga75yaid9n8bgb345ih5mwjp3plj6v1jxwb9n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/nir0s/distro")
+ (synopsis
+ "OS platform information API")
+ (description
+ "@code{distro} provides information about the OS distribution it runs on,
+such as a reliable machine-readable ID, or version information.
+
+It is the recommended replacement for Python's original
+`platform.linux_distribution` function (which will be removed in Python 3.8).
+@code{distro} also provides a command-line interface to output the platform
+information in various formats.")
+ (license license:asl2.0)))