summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 18:10:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 18:10:46 +0100
commitffe7029babb40481f50cf931b28e92c8f74dfe01 (patch)
tree8288aec8af1bc51fc2d8143a32b9170f843c7a9c /gnu/packages
parentf31e10f82e3bcfa74901f87b4a3d951758861804 (diff)
downloadpatches-ffe7029babb40481f50cf931b28e92c8f74dfe01.tar
patches-ffe7029babb40481f50cf931b28e92c8f74dfe01.tar.gz
gnu: Add r-aucell.
* gnu/packages/bioconductor.scm (r-aucell): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2d74d2628c..6a7c98f625 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3551,3 +3551,38 @@ text files).")
"This package provides a framework for allele-specific expression
investigation using RNA-seq data.")
(license license:gpl3)))
+
+(define-public r-aucell
+ (package
+ (name "r-aucell")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AUCell" version))
+ (sha256
+ (base32
+ "1kdrs0521cyb8wlc4i3idfprrcy2f9w6kl56hfa94n0brmx62ya9"))))
+ (properties `((upstream-name . "AUCell")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-gseabase" ,r-gseabase)
+ ("r-mixtools" ,r-mixtools)
+ ("r-r-utils" ,r-r-utils)
+ ("r-shiny" ,r-shiny)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (home-page "https://bioconductor.org/packages/AUCell/")
+ (synopsis "Analysis of gene set activity in single-cell RNA-seq data")
+ (description
+ "AUCell allows to identify cells with active gene sets (e.g. signatures,
+gene modules, etc) in single-cell RNA-seq data. AUCell uses the @dfn{Area
+Under the Curve} (AUC) to calculate whether a critical subset of the input
+gene set is enriched within the expressed genes for each cell. The
+distribution of AUC scores across all the cells allows exploring the relative
+expression of the signature. Since the scoring method is ranking-based,
+AUCell is independent of the gene expression units and the normalization
+procedure. In addition, since the cells are evaluated individually, it can
+easily be applied to bigger datasets, subsetting the expression matrix if
+needed.")
+ (license license:gpl3)))