summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-13 14:03:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 14:44:00 +0100
commiteccaa8bf8deafbce7bf65b9d3b2822add00219c0 (patch)
tree575dedf2073d2a1b1342bb8ff07eec815b93005f /gnu/packages
parentb165fe61dc6eaf96997973bee7d1bb98ca3e264b (diff)
downloadpatches-eccaa8bf8deafbce7bf65b9d3b2822add00219c0.tar
patches-eccaa8bf8deafbce7bf65b9d3b2822add00219c0.tar.gz
gnu: libsoup: Update to 2.66.0.
* gnu/packages/gnome.scm (libsoup): Update to 2.66.0. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Adjust accordingly. [native-inputs]: Add GTK-DOC. [inputs]: Add MIT-KRB5. Move SQLITE and LIBPSL ... [propagated-inputs]: ... here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm55
1 files changed, 22 insertions, 33 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3d67b7b9c1..2697beebca 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2561,7 +2561,7 @@ libxml to ease remote use of the RESTful API.")
(define-public libsoup
(package
(name "libsoup")
- (version "2.64.2")
+ (version "2.66.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/libsoup/"
@@ -2569,38 +2569,23 @@ libxml to ease remote use of the RESTful API.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1il6lyrmfi0hfh3ysw8w1qzc1rdz0igkb7dv6d8g5mmilnac3pbm"))))
- (build-system gnu-build-system)
+ "08c9kkdhzy504gv23pfdm4sq3dd3j20sikwz6gv0qrwcdjnw5bai"))))
+ (build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
`(#:modules ((guix build utils)
- (guix build gnu-build-system)
+ (guix build meson-build-system)
(ice-9 popen))
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html")
- (string-append "--with-apache-module-dir="
- (assoc-ref %build-inputs "httpd")
- "/modules"))
+ #:configure-flags '("-Ddoc=true")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'disable-unconnected-socket-test
- ;; This test fails due to missing /etc/nsswitch.conf
- ;; in the build environment.
+ (add-after 'unpack 'adjust-tests
(lambda _
+ ;; This test fails due to missing /etc/nsswitch.conf
+ ;; in the build environment.
(substitute* "tests/socket-test.c"
((".*/sockets/unconnected.*") ""))
- #t))
- (add-before 'check 'pre-check
- (lambda _
- ;; The 'check-local' target runs 'env LANG=C sort -u',
- ;; unset 'LC_ALL' to make 'LANG' working.
- (unsetenv "LC_ALL")
- ;; HTTPD in Guix uses mod_event and does not build prefork.
- (substitute* "tests/httpd.conf"
- (("^LoadModule mpm_prefork_module.*$") "\n"))
;; Generate a self-signed certificate that has "localhost" as its
;; 'dnsName'. Failing to do that, and starting with GnuTLS
@@ -2646,16 +2631,19 @@ libxml to ease remote use of the RESTful API.")
))
(close-pipe pipe))
#t))
- (replace 'install
- (lambda _
- (invoke "make"
- ;; Install vala bindings into $out.
- (string-append "vapidir=" %output
- "/share/vala/vapi")
- "install"))))))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (copy-recursively (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ (delete-file-recursively (string-append out "/share/gtk-doc"))
+ #t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
@@ -2668,11 +2656,12 @@ libxml to ease remote use of the RESTful API.")
(propagated-inputs
;; libsoup-2.4.pc refers to all these.
`(("glib" ,glib)
- ("libxml2" ,libxml2)))
- (inputs
- `(("glib-networking" ,glib-networking)
("libpsl" ,libpsl)
+ ("libxml2" ,libxml2)
("sqlite" ,sqlite)))
+ (inputs
+ `(("glib-networking" ,glib-networking)
+ ("mit-krb5" ,mit-krb5)))
(home-page "https://live.gnome.org/LibSoup/")
(synopsis "GLib-based HTTP Library")
(description