summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-25 07:06:08 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2019-03-30 17:03:57 +0300
commit29a9eb9e1a958414aae902dbb96fe01e90d2de89 (patch)
tree80b5dfc123bbd3c65921240722eddf7e60a3b6f1 /gnu/packages
parent03a33eee720d7173a438cd1ce3e8dedf89aaa1d4 (diff)
downloadpatches-29a9eb9e1a958414aae902dbb96fe01e90d2de89.tar
patches-29a9eb9e1a958414aae902dbb96fe01e90d2de89.tar.gz
gnu: Add emacs-counsel-projectile.
* gnu/packages/emacs-xyz.scm (emacs-counsel-projectile): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 51444d5687..df5e2cf21e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4406,6 +4406,30 @@ The purpose of this library is to wrap all the quirks and hassle of
@code{package.el} into a sane API.")
(license license:gpl3+)))
+(define-public emacs-counsel-projectile
+ (package
+ (name "emacs-counsel-projectile")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ericdanan/counsel-projectile")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1inc4ndl0ysfwvxk4avbgpj4qi9rc93da6476a5c81xmwpsv8wmq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ivy" ,emacs-ivy)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/ericdanan/counsel-projectile")
+ (synopsis "Enhance Projectile with Ivy")
+ (description
+ "This package uses Ivy to provide additional actions for Projectile
+commands and replacements for existing functions.")
+ (license license:gpl3+)))
+
(define-public emacs-queue
(package
(name "emacs-queue")