summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-14 14:07:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:47 +0200
commit7a9b737a8b07a9bef580296f280c9d8fe666a42d (patch)
treea28f3d81055f08f88aa3784033d32dd8225724fb /gnu/packages
parent57680dc2c58085a26d30b0c98299d5a586612cf5 (diff)
downloadpatches-7a9b737a8b07a9bef580296f280c9d8fe666a42d.tar
patches-7a9b737a8b07a9bef580296f280c9d8fe666a42d.tar.gz
gnu: Add texlive-docstrip.
* gnu/packages/tex.scm (texlive-docstrip): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d8cccfc227..85e458b919 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -413,6 +413,20 @@ This package contains the binaries.")
(home-page "https://www.tug.org/texlive/")))
+(define texlive-docstrip
+ (package
+ (inherit (simple-texlive-package
+ "texlive-docstrip"
+ (list "/tex/latex/base/docstrip.tex")
+ (base32
+ "17vdy43d9vknldz7wb69hp33r8awmdvn4xszamvgs5ikcl4cp289")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/texlive")
+ (synopsis "Utility to strip documentation from TeX files.")
+ (description "This package provides the docstrip utility to strip
+documentation from TeX files. It is part of the LaTeX base.")
+ (license license:lppl1.3+)))
+
(define-public texlive-unicode-data
(package
(inherit (simple-texlive-package