summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-27 20:37:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-03-28 09:38:27 +0300
commit04952bd7321c2607e51af2d11c1248d9462343ff (patch)
tree44b33c732a49d415155f0b78e49481d6480aa6eb /gnu/packages
parent84fb4bd90723a41d2dedb8daa5f99f47111356cb (diff)
downloadpatches-04952bd7321c2607e51af2d11c1248d9462343ff.tar
patches-04952bd7321c2607e51af2d11c1248d9462343ff.tar.gz
gnu: nspr: Use 'modify-phases' syntax.
* gnu/packages/gnuzilla.scm (nspr)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 4077ac7f30..bdb9e857a8 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -179,11 +179,9 @@ in C/C++.")
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
"/lib"))
- #:phases (alist-cons-before
- 'configure 'chdir
- (lambda _
- (chdir "nspr"))
- %standard-phases)))
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _ (chdir "nspr") #t)))))
(home-page
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR")
(synopsis "Netscape API for system level and libc-like functions")