summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-01 10:45:39 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-01 11:28:48 +0100
commitc03ba83c17c91e34e811a909fae0f63aab701ff9 (patch)
treefbedd9d2dba099fc367cc9c7237d8959ce5d44ee /gnu/packages
parentf8446df663fecb5aa34e5c6dfa477544d3271d1e (diff)
downloadpatches-c03ba83c17c91e34e811a909fae0f63aab701ff9.tar
patches-c03ba83c17c91e34e811a909fae0f63aab701ff9.tar.gz
gnu: git: Run tests sequentially.
Fixes <https://bugs.gnu.org/29512>. Reported by George myglc2 Clemmer <myglc2@gmail.com>. * gnu/packages/version-control.scm (git)[arguments]: Add #:parallel-tests?.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 21ea90be72..22b296f4a0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -188,6 +188,9 @@ as well as the classic centralized workflow.")
"NO_INSTALL_HARDLINKS=indeed")
#:test-target "test"
+ ;; Tests fail randomly when parallel: <https://bugs.gnu.org/29512>.
+ #:parallel-tests? #f
+
;; The explicit --with-tcltk forces the build system to hardcode the
;; absolute file name to 'wish'.
#:configure-flags (list (string-append "--with-tcltk="