summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-11-18 10:25:40 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-11-30 18:18:47 +0530
commitbf630276a1c853ec7484f5422d0595a11f51a58b (patch)
tree6a102518bb478283566b51d47de4cc96298611e2 /gnu/packages
parentc5b2905d92e7c34616fca2dc12d9df991f2d7d06 (diff)
downloadpatches-bf630276a1c853ec7484f5422d0595a11f51a58b.tar
patches-bf630276a1c853ec7484f5422d0595a11f51a58b.tar.gz
gnu: scons: Update to 3.0.1.
* gnu/packages/python.scm (scons): Update to 3.0.1. (scons-python2): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9e89e0d111..01b4e2cd29 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1365,19 +1365,17 @@ existing ones.")
(define-public scons
(package
(name "scons")
- (version "2.5.1")
+ (version "3.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/scons/scons/" version
"/scons-" version ".tar.gz"))
(sha256
(base32
- "1wji1z9jdkhnmm99apx6fhld9cs52rr56aigniyrcsmlwy52298b"))))
+ "0wzid419mlwqw9llrg8gsx4nkzhqy16m4m40r0xnh6cwscw5wir4"))))
(build-system python-build-system)
(arguments
- ;; With Python 3.x, fails to build with a syntax error.
- `(#:python ,python-2
- #:use-setuptools? #f ; still relies on distutils
+ `(#:use-setuptools? #f ; still relies on distutils
#:tests? #f)) ; no 'python setup.py test' command
(home-page "http://scons.org/")
(synopsis "Software construction tool written in Python")
@@ -1389,6 +1387,11 @@ In short, SCons is an easier, more reliable and faster way to build
software.")
(license license:x11)))
+(define-public scons-python2
+ (package
+ (inherit (package-with-python2 scons))
+ (name "scons-python2")))
+
(define-public python-extras
(package
(name "python-extras")