summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2018-03-29 13:39:40 +0200
committerLudovic Courtès <ludovic.courtes@inria.fr>2018-03-29 15:17:35 +0200
commit9c3f2c2e83e0970173fbbf77f699e2c325046daa (patch)
treeec1aca48f24a38c665007f2b15b7d52d534d0d2e /gnu/packages
parent594e5d73688bb75fe5efc6ae3c27b4689e16726d (diff)
downloadpatches-9c3f2c2e83e0970173fbbf77f699e2c325046daa.tar
patches-9c3f2c2e83e0970173fbbf77f699e2c325046daa.tar.gz
gnu: Add python-debug.
Suggested by Pjotr Prins <pjotr.public12@thebird.nl>. * gnu/packages/python.scm (python-debug): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 148cfb8bcd..9e038ef4fb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -401,6 +401,24 @@ data types.")
("openssl" ,openssl)
("zlib" ,zlib)))))
+(define-public python-debug
+ (package
+ (inherit python)
+ (name "python-debug")
+ (outputs '("out" "debug"))
+ (build-system gnu-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments python)
+ ((#:configure-flags flags '())
+ `(cons "--with-pydebug" ,flags))))
+ (synopsis
+ "High-level, dynamically-typed programming language (for debugging)")
+ (description
+ "This variant of Python provides an interpreter built with
+@code{--with-pydebug} to help develop and debug extensions. See
+@url{https://pythonextensionpatterns.readthedocs.io/en/latest/debugging/debug.html},
+for more information.")))
+
(define* (wrap-python3 python
#:optional
(name (string-append (package-name python) "-wrapper")))