summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-02 17:37:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-05 13:16:33 +0200
commit4a3ac362bbace262623e80cbfdfa3449736789cf (patch)
treea1d5c9d60a2f8ca57185cafbb5198bf74116a181 /gnu/packages
parent02dc4b8095750889f2e9c854d94fa2485bed2537 (diff)
downloadpatches-4a3ac362bbace262623e80cbfdfa3449736789cf.tar
patches-4a3ac362bbace262623e80cbfdfa3449736789cf.tar.gz
gnu: python-matplotlib: Update to 2.2.2.
* gnu/packages/python.scm (python-matplotlib): Update to 2.2.2. [propagated-inputs]: Add PYTHON-KIWISOLVER. (python2-matplotlib)[propagated-inputs]: Add PYTHON2-BACKPORTS-FUNCTOOLS-LRU-CACHE. (python-matplotlib-documentation)[native-inputs]: Change PYTHON-SPHINX to PYTHON-SPHINX-1.6. Add PYTHON-SPHINX-GALLERY.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7a4eee32ca..0eb6d73173 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3372,17 +3372,18 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(define-public python-matplotlib
(package
(name "python-matplotlib")
- (version "2.0.2")
+ (version "2.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "matplotlib" version))
(sha256
(base32
- "1w8z2a1l7s72p1byfz7g03wqhygqxi8w82619dqb3a1lm97w9yqg"))))
+ "1s6dv225w3k4fv52h8lfjc7qq5y56i9755ayx0mz48ddi99fzisd"))))
(build-system python-build-system)
(propagated-inputs ; the following packages are all needed at run time
`(("python-cycler" ,python-cycler)
+ ("python-kiwisolver" ,python-kiwisolver)
("python-pyparsing" ,python-pyparsing)
("python-pygobject" ,python-pygobject)
("gobject-introspection" ,gobject-introspection)
@@ -3462,6 +3463,8 @@ toolkits.")
;; of those automatically rewritten by package-with-python2.
(propagated-inputs
`(("python2-pycairo" ,python2-pycairo)
+ ("python2-backports-functools-lru-cache"
+ ,python2-backports-functools-lru-cache)
("python2-functools32" ,python2-functools32)
("python2-pygobject-2" ,python2-pygobject-2)
("python2-subprocess32" ,python2-subprocess32)
@@ -3478,7 +3481,8 @@ toolkits.")
(native-inputs
`(("python-matplotlib" ,python-matplotlib)
("python-colorspacious" ,python-colorspacious)
- ("python-sphinx" ,python-sphinx)
+ ("python-sphinx" ,python-sphinx-1.6)
+ ("python-sphinx-gallery" ,python-sphinx-gallery)
("python-numpydoc" ,python-numpydoc)
("python-ipython" ,python-ipython)
("python-mock" ,python-mock)
@@ -3501,7 +3505,7 @@ toolkits.")
(("latex_elements\\['pointsize'\\] = '11pt'" match)
;; insert at a point where latex_elements{} is defined:
(string-append match "\nlatex_elements['papersize'] = 'a4paper'")))
- (zero? (system* "python" "make.py" "html" "latex" "texinfo"))))
+ (invoke "make" "SPHINXBUILD=sphinx-build" "html" "latex" "texinfo")))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((data (string-append (assoc-ref outputs "out") "/share"))